Bug 1305745 - [GSS]Remove "samba" package from dependency of ctdb-4.2.4
[GSS]Remove "samba" package from dependency of ctdb-4.2.4
Status: CLOSED ERRATA
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: distribution (Show other bugs)
3.1
All All
medium Severity medium
: ---
: RHGS 3.1.2
Assigned To: Jose A. Rivera
surabhi
: ZStream
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-09 01:08 EST by Riyas Abdulrasak
Modified: 2016-03-01 01:10 EST (History)
9 users (show)

See Also:
Fixed In Version: samba-4.2.4-13
Doc Type: Bug Fix
Doc Text:
Due to a dependency in the packaging of Samba 4.2, it was not possible to install ctdb without installing Samba. With this update, this dependency has been resolved and now ctdb can be installed without installing Samba.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-03-01 01:10:07 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Riyas Abdulrasak 2016-02-09 01:08:15 EST
Description of problem:

There are customers who use "ctdb" with NFS and doesn't want to install samba packages on their gluster nodes. 

Some of them would like to upgrade ctdb-2.5.x to ctdb-4.2.4, don't want to install samba. 

Version-Release number of selected component (if applicable):

Red Hat Gluster Storage 3.1.1 on RHEL 7.2

How reproducible:
Always

Steps to Reproduce:
1. Install Red Hat Gluster Storage 3.1.1 on RHEL 7.2
2. Try to upgrade CTDB 2.5 to ctdb-4.2.4 using yum. It is installing samba packages as dependency. 



Actual results:

ependencies Resolved
==============================================================================================================================================================================================

 Package                                     Arch                           Version                                   Repository                                                         Size

==============================================================================================================================================================================================

Installing:

 ctdb                                        x86_64                         4.2.4-9.1.el7rhgs                         rh-gluster-3-samba-for-rhel-7-server-rpms                         471 k

Installing for dependencies:

 libwbclient                                 x86_64                         4.2.4-9.1.el7rhgs                         rh-gluster-3-samba-for-rhel-7-server-rpms                          95 k

 pytalloc                                    x86_64                         2.1.2-1.el7rhgs                           rh-gluster-3-samba-for-rhel-7-server-rpms                          12 k

 samba                                       x86_64                         4.2.4-9.1.el7rhgs                         rh-gluster-3-samba-for-rhel-7-server-rpms                         605 k

 samba-client-libs                           x86_64                         4.2.4-9.1.el7rhgs                         rh-gluster-3-samba-for-rhel-7-server-rpms                         4.3 M

 samba-common                                noarch                         4.2.4-9.1.el7rhgs                         rh-gluster-3-samba-for-rhel-7-server-rpms                         270 k

 samba-common-libs                           x86_64                         4.2.4-9.1.el7rhgs                         rh-gluster-3-samba-for-rhel-7-server-rpms                         155 k

 samba-common-tools                          x86_64                         4.2.4-9.1.el7rhgs                         rh-gluster-3-samba-for-rhel-7-server-rpms                         443 k

 samba-libs                                  x86_64                         4.2.4-9.1.el7rhgs                         rh-gluster-3-samba-for-rhel-7-server-rpms                         258 k

 samba-vfs-glusterfs                         x86_64                         4.2.4-9.1.el7rhgs                         rh-gluster-3-samba-for-rhel-7-server-rpms                          84 k

Updating for dependencies:

 libtalloc                                   x86_64                         2.1.2-1.el7rhgs                           rh-gluster-3-samba-for-rhel-7-server-rpms                          29 k

~~~~~~~




Expected results:

ctdb-2.5 be able to upgrade to ctdb-4.x without installing samba packages. 


Additional info:
Comment 1 Michael Adam 2016-02-09 19:07:41 EST
As already discussed by mail, currently it is not possible to install ctdb without installing samba from the rhgs channel due to these dependencies:

~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
ctdb
-> samba-client-libs
   -> samba-common
     -> samba-vfs-gluster
        -> samba
        -> samba-libs
        -> glusterfs
        -> glusterfs-api
     -> samba-common-tools
        -> samba-common-libs
        -> samba-libs
   -> libwbclient
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

We will fix the deps and ship an update.
The fix will consist in removing the
dependency to samba-vfs-glusterfs from samba-common.
This will require explicit installation of samba-vfs-glusterfs.

Not sure in which release we would ship this fix though. (3.1.2 or later?)
Comment 6 Jose A. Rivera 2016-02-12 01:43:49 EST
Looks fixed in latest builds:

RHEL6: https://brewweb.devel.redhat.com//buildinfo?buildID=479855
RHEL7: https://brewweb.devel.redhat.com//buildinfo?buildID=479854
Comment 7 surabhi 2016-02-12 03:06:22 EST
Jose,

Does this build contains following two fixes or any other change?

1. Remove samba-vfs-glusterfs dependency from samba-common
2. Add a dep of samba-vfs-glusterfs to samba main pkg
Comment 8 Michael Adam 2016-02-12 03:14:05 EST
(In reply to surabhi from comment #7)
> Jose,
> 
> Does this build contains following two fixes or any other change?
> 
> 1. Remove samba-vfs-glusterfs dependency from samba-common
> 2. Add a dep of samba-vfs-glusterfs to samba main pkg

This build contains exactly those two changes compared
to the last build (-12).
Comment 9 surabhi 2016-02-12 14:27:02 EST
Verified as follows on RHEL6:

1.Install RHGS3.1 ISO
2. Subscribe to Live, add rhel,rhgs channel
3. Yum update
4. yum install ctdb (Which will install ctdb2.5 package in Live)
Note : No samba installed yet.
5. Add samba channel + latest puddles
6. yum update (CTDB gets updated to ctdb-4.2.4-13 without installing samba main and samba-vfs-glusterfs package)

*************************************************************************
cat /etc/redhat-release 
Red Hat Enterprise Linux Server release 6.7 (Santiago)
cat /etc/redhat-storage-release 
Red Hat Gluster Storage Server 3.1 Update 1

rpm -qa | grep ctdb
ctdb2.5-2.5.5-7.el6rhs.x86_64

Installing:
 ctdb                                       x86_64                  4.2.4-13.el6rhs                        RH-Gluster-3-Samba-                  494 k
     replacing  ctdb2.5.x86_64 2.5.5-7.el6rhs
Updating:
 gluster-nagios-common                      noarch                  0.2.3-1.el6rhs                         RH-Gluster-3-Server                   30 k
 glusterfs                                  x86_64                  3.7.5-19.el6rhs                        RH-Gluster-3-Server                  393 k
 glusterfs-api                              x86_64                  3.7.5-19.el6rhs                        RH-Gluster-3-Server                   56 k
 glusterfs-cli                              x86_64                  3.7.5-19.el6rhs                        RH-Gluster-3-Server                  154 k
 glusterfs-client-xlators                   x86_64                  3.7.5-19.el6rhs                        RH-Gluster-3-Server                  942 k
 glusterfs-fuse                             x86_64                  3.7.5-19.el6rhs                        RH-Gluster-3-Server                  103 k
 glusterfs-geo-replication                  x86_64                  3.7.5-19.el6rhs                        RH-Gluster-3-Server                  172 k
 glusterfs-libs                             x86_64                  3.7.5-19.el6rhs                        RH-Gluster-3-Server                  303 k
 glusterfs-rdma                             x86_64                  3.7.5-19.el6rhs                        RH-Gluster-3-Server                   37 k
 glusterfs-server                           x86_64                  3.7.5-19.el6rhs                        RH-Gluster-3-Server                  1.3 M
 libtalloc                                  x86_64                  2.1.2-1.el6rhs                         RH-Gluster-3-Samba-                   25 k
 libtdb                                     x86_64                  1.3.6-2.el6rhs                         RH-Gluster-3-Samba-                   41 k
 libtevent                                  x86_64                  0.9.25-1.el6rhs                        RH-Gluster-3-Samba-                   29 k
 nrpe                                       x86_64                  2.15-4.2.el6rhs                        RH-Gluster-3-Server                  225 k
 nsca-client                                x86_64                  2.9.1-4.1.el6rhs                       RH-Gluster-3-Server                   22 k
 python-gluster                             noarch                  3.7.5-19.el6rhs                        RH-Gluster-3-Server                  7.8 k
 redhat-storage-server                      noarch                  3.1.2.0-1.el6rhs                       RH-Gluster-3-Server                  1.3 M
 tdb-tools                                  x86_64                  1.3.6-2.el6rhs                         RH-Gluster-3-Samba-                   25 k
 vdsm                                       x86_64                  4.16.30-1.3.el6rhs                     RH-Gluster-3-Server                  883 k
 vdsm-cli                                   noarch                  4.16.30-1.3.el6rhs                     RH-Gluster-3-Server                   64 k
 vdsm-gluster                               noarch                  4.16.30-1.3.el6rhs                     RH-Gluster-3-Server                   57 k
 vdsm-jsonrpc                               noarch                  4.16.30-1.3.el6rhs                     RH-Gluster-3-Server                   96 k
 vdsm-python                                noarch                  4.16.30-1.3.el6rhs                     RH-Gluster-3-Server                  175 k
 vdsm-python-zombiereaper                   noarch                  4.16.30-1.3.el6rhs                     RH-Gluster-3-Server                  6.5 k
 vdsm-reg                                   noarch                  4.16.30-1.3.el6rhs                     RH-Gluster-3-Server                   60 k
 vdsm-xmlrpc                                noarch                  4.16.30-1.3.el6rhs                     RH-Gluster-3-Server                   25 k
 vdsm-yajsonrpc                             noarch                  4.16.30-1.3.el6rhs                     RH-Gluster-3-Server                   26 k
Installing for dependencies:
 libwbclient                                x86_64                  4.2.4-13.el6rhs                        RH-Gluster-3-Samba-                   91 k
 pytalloc                                   x86_64                  2.1.2-1.el6rhs                         RH-Gluster-3-Samba-                  9.1 k
 samba-client-libs                          x86_64                  4.2.4-13.el6rhs                        RH-Gluster-3-Samba-                  4.2 M
 samba-common                               noarch                  4.2.4-13.el6rhs                        RH-Gluster-3-Samba-                  269 k
 samba-common-libs                          x86_64                  4.2.4-13.el6rhs                        RH-Gluster-3-Samba-                  149 k
 samba-common-tools                         x86_64                  4.2.4-13.el6rhs                        RH-Gluster-3-Samba-                  434 k
 samba-libs                                 x86_64                  4.2.4-13.el6rhs                        RH-Gluster-3-Samba-                  244 k

Transaction Summary
======================================================================================================================================================
Install       8 Package(s)
Upgrade      27 Package(s)


rpm -qa | grep ctdb
ctdb-4.2.4-13.el6rhs.x86_64
*************************************************************************

Verified on RHEL6, looks fine. Will be verifying on RHEL7 and will update the results soon.
Comment 10 surabhi 2016-02-16 04:36:03 EST
Verified with RHEL7.

Install 3.1 rhel7 iso
Update from Live
yum install ctdb 

rpm -qa | grep ctdb
ctdb2.5.x86_64 0:2.5.5-7.el7rhgs 

add samba channel 
yum update
samba will also get installed because of this BZ.

Now add puddles to get latest CTDB package with the fix .

1. If we do yum update it will update all the packages including samba package.
Everything will updated to latest including samba package.

From 3.1.2 onwards the ctdb package will not pull in the samba main package as dependency.
Comment 13 Michael Adam 2016-02-24 05:44:21 EST
Looks good to me. Thanks.
Comment 15 errata-xmlrpc 2016-03-01 01:10:07 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-0326.html

Note You need to log in before you can comment on or make changes to this bug.