Bug 1305750 - RestClient error while yum updating satellite packages during upgrade.
RestClient error while yum updating satellite packages during upgrade.
Status: CLOSED NOTABUG
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Upgrades (Show other bugs)
Unspecified
Unspecified Unspecified
unspecified Severity medium (vote)
: 6.1.7
: --
Assigned To: satellite6-bugs
Katello QA List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-09 01:21 EST by Jitendra Yejare
Modified: 2017-02-23 14:38 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-09 13:46:45 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Satellite Foreman-debug on RHEL 67 (1.17 MB, application/x-xz)
2016-02-09 01:21 EST, Jitendra Yejare
no flags Details
Satellite Foreman-debug on RHEL 72 (1.36 MB, application/x-xz)
2016-02-09 01:22 EST, Jitendra Yejare
no flags Details

  None (edit)
Description Jitendra Yejare 2016-02-09 01:21:15 EST
Created attachment 1122343 [details]
Satellite Foreman-debug on RHEL 67

Description of problem:
----------------------------
RestClient error in /var/log/foreman/production.log while yum updating the satellite packages in satellite upgrade.

Version-Release number of selected component (if applicable):
Satellite 6.1.7 Snap 1

How reproducible:
---------------------------

Steps to Reproduce:
1. Attempt to upgrade Satellite from 6.1.6 CDN version to 6.1.7 #c1.
2. While yum updating the satellite packages during upgrade observe /var/log/foreman/production.log logs.


Actual results:
--------------------------
RestClient Error in logs as below:

In Satellite 6.7 : ERROR 2016-02-03 08:39:29 pulp_rest  #5551] RestClient.get "https://sat616-qe-rhel67.usersys.redhat.com/pulp/api/v2/events/", "Accept"=>"*/*; q=0.5, application/xml", "Accept-Encoding"=>"gzip, deflate", "Authorization"=>"OAuth oauth_consumer_key=\"katello\", oauth_nonce=\"O99Eu91BcVWQQCWZ3whS4EWqyqM03SXk7pNi92I0\", oauth_signature=\"3YJiqZHsDPW%2FmC4vkujW72Loyw8%3D\", oauth_signature_method=\"HMAC-SHA1\", oauth_timestamp=\"1454506769\", oauth_version=\"1.0\"", "accept"=>"application/json", "content_type"=>"application/json", "pulp-user"=>"admin"
 |
2016-02-03 08:39:29 [I] shutting down Core ...

In Satellite 7.2 : [ERROR 2016-02-05 03:32:59 pulp_rest  #4056] RestClient.get "https://sat616-qe-rhel72.usersys.redhat.com/pulp/api/v2/events/", "Accept"=>"*/*; q=0.5, application/xml", "Accept-Encoding"=>"gzip, deflate", "Authorization"=>"OAuth oauth_consumer_key=\"katello\", oauth_nonce=\"6vnuN6ao1dvaZ58nccCCovRSdvgDDcQKXIYKSH9cj6c\", oauth_signature=\"YtpEWsfJPfzY3%2Fy3rQXzL6h8iEI%3D\", oauth_signature_method=\"HMAC-SHA1\", oauth_timestamp=\"1454661179\", oauth_version=\"1.0\"", "accept"=>"application/json", "content_type"=>"application/json", "pulp-user"=>"admin"
 |
2016-02-05 03:32:59 [I] shutting down Core ...

Expected results:
-----------------------
No RestClient error.
Comment 1 Jitendra Yejare 2016-02-09 01:22 EST
Created attachment 1122344 [details]
Satellite Foreman-debug on RHEL 72
Comment 3 Mike McCune 2016-02-09 13:46:45 EST
As things get shut down and restarted, I'd expect to see errors in the logs, IMO this is not a bug if we are not seeing any ill effects.

If you feel differently, please re-open.

Note You need to log in before you can comment on or make changes to this bug.