Bug 1305760 - libisds-0.10.2-2.fc24 FTBFS: warning about indentation
libisds-0.10.2-2.fc24 FTBFS: warning about indentation
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: libisds (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Petr Pisar
Fedora Extras Quality Assurance
https://koji.fedoraproject.org/koji/t...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-09 02:36 EST by Petr Pisar
Modified: 2016-02-09 02:59 EST (History)
1 user (show)

See Also:
Fixed In Version: libisds-0.10.2-3.fc24
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-09 02:59:40 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Petr Pisar 2016-02-09 02:36:03 EST
libisds-0.10.2-2.fc24 fails to build in F24:

http.c: In function 'base64_encode_blockend':
http.c:138:2: error: statement is indented as if it were guarded by... [-Werror=misleading-indentation]
  return codechar - code_out;
  ^~~~~~
http.c:135:5: note: ...this 'if' clause, but it is not
     if (state_in->stepcount >= 0)
     ^~

This is caused by GCC 6 that introduces a new warning class.

Note You need to log in before you can comment on or make changes to this bug.