Bug 130580 - squid missing IPv6 support
squid missing IPv6 support
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: squid (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Martin Stransky
: Reopened
Depends On:
Blocks: 181490 IPv6Blocker
  Show dependency treegraph
 
Reported: 2004-08-22 05:09 EDT by Thomas Zehetbauer
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-08 06:21:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Thomas Zehetbauer 2004-08-22 05:09:33 EDT
Current squid-2.5.STABLE5-5.x86_64 does not support IPv6.
Comment 1 Robert Scheck 2004-08-28 19:38:29 EDT
I think squid doesn't in any currently by Red Hat delivered version 
provide IPv6 support - platform independent.

I searched around a bit and noticed, that

  http://www.init.ca/debian/squid-IPv6/

provides IPv6 support but bases on cvs branch "squid-ipv6" and 
porting seems very hard to me (maybe because I'm not a good c 
expert), but a diff between the current Red Hat delivered version 
and the cvs snapshot of the squid-ipv6 branch shows lots of 
differences which must be very carefully ported.

But I also heard and read, that the current squid unstable has IPv6 
enabled, I didn't verify that yet, because Red Hat also isn't willing  
to ship development upstream versions...Bill Nottingham told me that 
a few days ago (but he even said this friendlier *smile*).

As long as missing IPv6 support is no major issue nobody of the Red 
Hat people will work out a patch, I think :-(

But I'm curious what's going up with IPv6 support in squid at Fedora 
now, because it's a (with the time) increasing issue...

Maybe also relevant links:
http://cvs.sourceforge.net/viewcvs.py/squid/squid/?only_with_tag=ipv6
http://devel.squid-cache.org/ipv6/
Comment 2 Jay Fenlason 2004-09-28 15:55:17 EDT
This needs to be fixed upstream before we can ship an ipv6-enabled 
squid.  File it in 
http://www.squid-cache.org/bugs/index.cgi 
or (best bet) help the squid folks get squid-3.0 final out, so that 
ipv6 support can be merged into it. 
Comment 3 David Woodhouse 2006-06-14 16:15:46 EDT
Reopening, attaching to IPv6 blocker bug.
Comment 6 Martin Stransky 2006-08-08 06:24:32 EDT
ipv6 support is in squid-3.0 (current unstable version) so we should wait to
first stable 3.0... 

Note You need to log in before you can comment on or make changes to this bug.