Bug 1305809 - [Cinder] - Running a stateless VM leaves a locked snapshot and the VM cannot be started
[Cinder] - Running a stateless VM leaves a locked snapshot and the VM cannot ...
Status: CLOSED CURRENTRELEASE
Product: ovirt-engine
Classification: oVirt
Component: BLL.Storage (Show other bugs)
3.6.3.1
Unspecified Unspecified
high Severity high (vote)
: ovirt-3.6.3
: 3.6.3.2
Assigned To: Maor
Natalie Gavrielov
:
Depends On:
Blocks: 1270725 1288157
  Show dependency treegraph
 
Reported: 2016-02-09 05:03 EST by Maor
Modified: 2016-02-23 08:31 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-23 08:31:55 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Storage
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
tnisan: ovirt‑3.6.z?
ylavi: exception?
rule-engine: planning_ack+
tnisan: devel_ack+
rule-engine: testing_ack?


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 53492 master MERGED core: Use Callback for RunVmCommand. 2016-02-14 14:36 EST
oVirt gerrit 53493 master MERGED core: Validate steps using CoCo on RunVmCommand 2016-02-14 14:35 EST
oVirt gerrit 53494 master MERGED core: RunVmCommand using callbacks 2016-02-14 14:35 EST
oVirt gerrit 53495 master MERGED core: Set parent command for child comamnd. 2016-02-14 14:35 EST
oVirt gerrit 53501 master MERGED core: Support mixed disk types for stateless VM. 2016-02-14 14:35 EST
oVirt gerrit 53509 master MERGED core: Remove redundant command line 2016-02-15 06:01 EST
oVirt gerrit 53511 ovirt-engine-3.6 MERGED core: Use Callback for RunVmCommand. 2016-02-15 07:26 EST
oVirt gerrit 53512 ovirt-engine-3.6 MERGED core: Validate steps using CoCo on RunVmCommand 2016-02-15 07:29 EST
oVirt gerrit 53513 ovirt-engine-3.6 MERGED core: RunVmCommand using callbacks 2016-02-15 07:31 EST
oVirt gerrit 53514 ovirt-engine-3.6 MERGED core: Set parent command for child comamnd. 2016-02-15 07:32 EST
oVirt gerrit 53535 ovirt-engine-3.6.3 MERGED core: Use Callback for RunVmCommand. 2016-02-15 12:30 EST
oVirt gerrit 53536 ovirt-engine-3.6.3 MERGED core: Validate steps using CoCo on RunVmCommand 2016-02-15 12:31 EST
oVirt gerrit 53537 ovirt-engine-3.6.3 MERGED core: RunVmCommand using callbacks 2016-02-15 12:32 EST
oVirt gerrit 53538 ovirt-engine-3.6.3 MERGED core: Set parent command for child comamnd. 2016-02-15 12:33 EST

  None (edit)
Description Maor 2016-02-09 05:03:04 EST
Description of problem:
Following the fix of create snapshot with Cinder disks for failure flow, 
The child command callback does not call the parent any more, but it is
all being done through ConcurrentChildCommandsExecutionCallback.

For stateless VM, part of the logic is to create a stateless snapshot
which being called from RunVmCommand.

before introducing ConcurrentChildCommandsExecutionCallback the
end action was called from CreateCinderSnapshotCommand endCommand though now
running a stateless VM creates a stateless snapshot and leaves the snapshot in lock status.
    
Version-Release number of selected component (if applicable):


How reproducible:
100%

Steps to Reproduce:
1. Run a stateless VM with Cinder disk
2.
3.

Actual results:
The stateless snapshot is in lock status for ever.

Expected results:
The stateless snapshot should be created and the stateless VM should run

Additional info:
Comment 1 Red Hat Bugzilla Rules Engine 2016-02-09 05:03:05 EST
Bug tickets must have version flags set prior to targeting them to a release. Please ask maintainer to set the correct version flags and only then set the target milestone.
Comment 2 Red Hat Bugzilla Rules Engine 2016-02-09 05:03:05 EST
Target release should be placed once a package build is known to fix a issue. Since this bug is not modified, the target version has been reset. Please use target milestone to plan a fix for a oVirt release.

Note You need to log in before you can comment on or make changes to this bug.