Bug 1305818 - [pacemaker-libs-devel] pkgconfig files contain unresolved PACKAGE_URL
[pacemaker-libs-devel] pkgconfig files contain unresolved PACKAGE_URL
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: pacemaker (Show other bugs)
6.5
Unspecified Unspecified
low Severity low
: rc
: 6.8
Assigned To: Ken Gaillot
cluster-qe@redhat.com
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-09 05:19 EST by Jan Pokorný
Modified: 2016-05-10 19:52 EDT (History)
5 users (show)

See Also:
Fixed In Version: pacemaker-1.1.14-3.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-05-10 19:52:50 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:0856 normal SHIPPED_LIVE pacemaker bug fix and enhancement update 2016-05-10 18:44:25 EDT

  None (edit)
Description Jan Pokorný 2016-02-09 05:19:15 EST
# grep PACKAGE_URL  /usr/lib*/pkgconfig/pacemaker*.pc 
> /usr/lib64/pkgconfig/pacemaker-cib.pc:URL:            @PACKAGE_URL@
> /usr/lib64/pkgconfig/pacemaker-cluster.pc:URL:        @PACKAGE_URL@
> /usr/lib64/pkgconfig/pacemaker-fencing.pc:URL:        @PACKAGE_URL@
> /usr/lib64/pkgconfig/pacemaker-lrmd.pc:URL:           @PACKAGE_URL@
> /usr/lib64/pkgconfig/pacemaker.pc:URL:        @PACKAGE_URL@
> /usr/lib64/pkgconfig/pacemaker-pengine.pc:URL:        @PACKAGE_URL@
> /usr/lib64/pkgconfig/pacemaker-service.pc:URL:        @PACKAGE_URL@

Proposed fix:
https://github.com/ClusterLabs/pacemaker/pull/914/
Comment 2 Jan Pokorný 2016-02-15 08:28:41 EST
Doesn't look it would be critical for anybody and the scope of PACKAGE_URL
is pretty limited (basically [comment 0], nothing more).
It would be more of a concern, if we were propagating that value in to
the docs (which might be a good idea, to have a single point of authority).

6.9+ is pretty fine (or anytime a patch adding PACKAGE_URL in more serious
context would be added).
Comment 3 Ken Gaillot 2016-02-17 17:33:27 EST
Fixed upstream as of d21fc64

There is one other minor change that would be good to get into 6.8, and if we can get approval for that, I'll try to combine this with it
Comment 4 Ken Gaillot 2016-02-17 18:22:29 EST
Bumping to 6.9 again, it turns out the other desired change is already in the current 6.8 build.
Comment 5 Ken Gaillot 2016-02-24 19:22:56 EST
Getting this in 6.8 after all because another issue came up. Fixed both as part of a new build for the rebase bz #1252206 since it's too late in the release cycle to do otherwise.
Comment 6 Jan Pokorný 2016-02-25 12:09:11 EST
Thanks!
Comment 11 errata-xmlrpc 2016-05-10 19:52:50 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-0856.html

Note You need to log in before you can comment on or make changes to this bug.