Bug 130584 - rngd looks for /dev/hw_random not /dev/hwrng
Summary: rngd looks for /dev/hw_random not /dev/hwrng
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel-utils   
(Show other bugs)
Version: rawhide
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Arjan van de Ven
QA Contact: Brian Brock
URL: http://www.redhat.com/archives/fedora...
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-08-22 11:43 UTC by Russell Coker
Modified: 2007-11-30 22:10 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-08-22 13:04:50 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Russell Coker 2004-08-22 11:43:23 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (compatible; Konqueror/3.3; Linux) (KHTML, like Gecko)

Description of problem:
The kernel devices.txt indicates that the hardware random number generator should be /dev/hwrng.  The program /sbin/rngd looks for /dev/hw_random, it should be changed to conform with the LANANA device names.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
Type "rngd" as root.

Actual Results:  Error that it can't open /dev/hw_random.

Expected Results:  Error that it can't open /dev/hwrng because udev does not create /dev/hwrng.

Additional info:

Comment 1 Arjan van de Ven 2004-08-22 13:04:50 UTC
we don't follow lanana but the udev convention


Note You need to log in before you can comment on or make changes to this bug.