Bug 1305842 - cannot download sources
cannot download sources
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
22
All Linux
unspecified Severity urgent
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-09 06:34 EST by Richard Jasmin
Modified: 2016-02-09 08:38 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-09 08:38:04 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Richard Jasmin 2016-02-09 06:34:00 EST
Description of problem:
This is a violation and something is broken here.

kernel sources cannot be found, let alone installed. Adding the source repo does not show them(yumex). Using the documented option to do so, does not work and FAILS.
"Can not load RPM file: kernel"

"
No package kernel-4.3.4-200 available.
Exiting due to strict setting.
Error: No package kernel-4.3.4-200 available.

 $ ls /lib/modules
4.0.4-301.fc22.x86_64  4.3.4-200.fc22.x86_64

"

All I want is the sources, I dont want to customize a kernel.I have experience in doing so, but as you know, any kernel update renders the custom kernel useless.And believe you me, plenty of us custom kernel.

This is a violation. Sources(of free) GPL software MUST be distributed either with the distro, or be made publicly available. To FAIL to do so is a FSF(and GPL) violation.

Either fix the mistake in hosting or fork over the sources.

True I can beg Torvaldis for them, but Im sure youve patched them in places.

This may be overkill for a kmod, but certainly will not hurt.

Version-Release number of selected component (if applicable):
22

How reproducible:
always

Steps to Reproduce:
N/A, no method succeeds.

Actual results:
!!!

Expected results:
This should NEVER EVER be.

Additional info:
https://fedoraproject.org/wiki/Building_a_custom_kernel#Get_the_Source
Comment 1 Josh Boyer 2016-02-09 08:38:04 EST
The sources are always available in the build system.  The repo creation only keeps the latest kernel in the updates repo, so to find the SRPM for the older kernel packages you need to look in koji.

http://koji.fedoraproject.org/koji/packageinfo?packageID=8

Note You need to log in before you can comment on or make changes to this bug.