Bug 1305872 - Port to python3 [NEEDINFO]
Port to python3
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: binclock (Show other bugs)
24
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miro Hrončok
Fedora Extras Quality Assurance
:
Depends On:
Blocks: PYTHON3 PY3PATCH-PUSH
  Show dependency treegraph
 
Reported: 2016-02-09 07:54 EST by Pavel Prochazka
Modified: 2016-08-27 06:26 EDT (History)
6 users (show)

See Also:
Fixed In Version: binclock-0.4.0-1.fc25
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-08-27 06:26:57 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
lbalhar: needinfo? (prochazka)


Attachments (Terms of Use)
patch (27.94 KB, application/mbox)
2016-02-09 07:54 EST, Pavel Prochazka
no flags Details
New specfile (2.58 KB, text/plain)
2016-08-10 05:31 EDT, Lumír Balhar
no flags Details

  None (edit)
Description Pavel Prochazka 2016-02-09 07:54:14 EST
Created attachment 1122402 [details]
patch

Please use git am with my patch.
Comment 1 Tomas Orsava 2016-02-12 07:43:46 EST
Hi Pavel, I was wondering, have you tried sending your patch upstream? If so, have you gotten any response?
Thanks
Comment 2 Jan Kurik 2016-02-24 09:27:21 EST
This bug appears to have been reported against 'rawhide' during the Fedora 24 development cycle.
Changing version to '24'.

More information and reason for this action is here:
https://fedoraproject.org/wiki/Fedora_Program_Management/HouseKeeping/Fedora24#Rawhide_Rebase
Comment 3 Lumír Balhar 2016-07-27 07:27:26 EDT
I've sent inner patch 'binclock-python3.patch' to upstream developer. If we will have no response, we can add this patch to package and apply changes to specfile.
Comment 4 Lumír Balhar 2016-08-01 03:06:01 EDT
I found only one developer's email address brian@linuxee.sk but this address doesn't work.

IMHO this patch is too big to be only in fedora package repository. Could you consider to maintain your own fork of this software? I think it would be better because next time when somebody will need to make some change he/she will have to change this big patch and this will be hard.

What do you think about it? If you have not enough time to do it or need some help do not hesitate to contact us.
Comment 5 Lumír Balhar 2016-08-10 03:27:47 EDT
Hello.

I've created new GitHub repo with link to original SourceForge project page [0]. I've also requested rights for this package in PkgDB to be a comantainer.

If maintainer gives mi access to PkgDB repository then I can move this forward.

[0] https://github.com/frenzymadness/binclock

Have a nice day
Comment 6 Lumír Balhar 2016-08-10 05:31 EDT
Created attachment 1189535 [details]
New specfile

And here is new modernized specfile with new upstream version and source URL.

Koji scratch build: http://koji.fedoraproject.org/koji/taskinfo?taskID=15199992

If maintainer has nothing against, we can push this changes.
Comment 7 Lumír Balhar 2016-08-17 03:45:46 EDT
One more week without a reply. I think we can push it.
Comment 8 Miro Hrončok 2016-08-17 04:14:11 EDT
Rawhide: http://koji.fedoraproject.org/koji/taskinfo?taskID=15284022
Comment 9 Fedora Update System 2016-08-17 04:22:11 EDT
binclock-0.4.0-1.fc25 has been submitted as an update to Fedora 25. https://bodhi.fedoraproject.org/updates/FEDORA-2016-d02534a451
Comment 10 Fedora Update System 2016-08-17 15:53:41 EDT
binclock-0.4.0-1.fc25 has been pushed to the Fedora 25 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-d02534a451
Comment 11 Fedora Update System 2016-08-27 06:26:53 EDT
binclock-0.4.0-1.fc25 has been pushed to the Fedora 25 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.