Bug 1305881 - jaxb-impl missing from zanata-client distribution
jaxb-impl missing from zanata-client distribution
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: zanata-client (Show other bugs)
23
All All
unspecified Severity unspecified
: ---
: ---
Assigned To: Patrick Huang
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-09 08:34 EST by Ricky Christie
Modified: 2016-08-04 19:44 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-08-04 19:44:15 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ricky Christie 2016-02-09 08:34:15 EST
First of all, thanks for open sourcing Aanata.
Apologize in advance if this is the wrong place to file this bug.

Description of problem:
When running zanata-cli -e pull in an XLIFF project, I get an error because jaxb-impl-2.2.4.jar isn't inside lib directory.

Version-Release number of selected component (if applicable):
Reproduced this on zanata-client 3.8.1 and 3.9.0-SNAPSHOT I found on http://repository-zanata.forge.cloudbees.com/snapshot/org/zanata/zanata-cli/


How reproducible:
Always


Steps to Reproduce:
1. Create xliff project with zanata-init. 
2. Push xliff files.
3. Pull xliff with zanata-cli -e pull command. 

Actual results:
The following exception:

Exception in thread "main" java.lang.NoClassDefFoundError: com/sun/xml/txw2/output/IndentingXMLStreamWriter
	at org.zanata.adapter.xliff.XliffWriter.writeFile(XliffWriter.java:206)
	at org.zanata.adapter.xliff.XliffWriter.write(XliffWriter.java:179)
	at org.zanata.client.commands.pull.XliffStrategy.writeTransFile(XliffStrategy.java:64)
	at org.zanata.client.commands.pull.PullCommand.writeTargetDoc(PullCommand.java:423)

Expected results:
No exception, pull would just work.

Additional info:
I fixed this by downloading jaxb-impl-2.2.4.jar directly from maven and editing zanata-cli classpath to include it. It then pulled correctly.
Comment 1 Sean Flanigan 2016-08-03 20:35:36 EDT
Patrick, has this been fixed?
Comment 2 Patrick Huang 2016-08-04 19:43:50 EDT
Tested with docker fedora 23. zanata client version 3.9.1. Fixed.

Note You need to log in before you can comment on or make changes to this bug.