Bug 130589 - No fstab entry added for USB camera
Summary: No fstab entry added for USB camera
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: hal
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: John (J5) Palmieri
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: FC3Target
TreeView+ depends on / blocked
 
Reported: 2004-08-22 14:07 UTC by Tim Waugh
Modified: 2013-03-13 04:46 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2004-08-23 21:38:15 UTC


Attachments (Terms of Use)

Description Tim Waugh 2004-08-22 14:07:40 UTC
Description of problem:
When I plug in my USB camera I don't get any entry added to
/etc/fstab.  I have to mount it manually with 'mount /dev/sdc1
/mnt/camera'.  There are no subdirectories in /media.

Version-Release number of selected component (if applicable):
hal-0.2.97.cvs20040819-1

How reproducible:
100%

Additional info:
This stuff all used to work fine with hotplug/kudzu.

Comment 1 David Zeuthen 2004-08-22 14:16:05 UTC
I need two things.

1. With your camera plugged in, powered up and mounted please post the
output from lshal(1). 

2. Plug out your camera; stop the hal daemon (service haldaemon stop)
and paste the output from this

# hald --daemon=no

(wait 10-20 secs, then plug in your camera)

Thanks,
David


Comment 2 Tim Waugh 2004-08-23 12:36:04 UTC
I think the problem was the missing fstab-sync symlink.

See:

http://www.redhat.com/archives/fedora-devel-list/2004-August/msg00859.html

for a suggested change to the package scriptlets.

Comment 3 David Zeuthen 2004-08-23 21:38:15 UTC
The package is now installing the symlink and it's now called
50-fstab-sync.hal (all HAL callouts now need to have the .hal suffix).
I have uploaded a new pacakge hal-0.2.97.cvs20040823-1 to Rawhide with
this fix.


Note You need to log in before you can comment on or make changes to this bug.