Bug 1305897 - build failing in collection-aware environment
build failing in collection-aware environment
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: scap-workbench (Show other bugs)
7.2
Unspecified Unspecified
unspecified Severity low
: rc
: ---
Assigned To: Martin Preisler
Marek Haicman
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-09 09:28 EST by Marek Haicman
Modified: 2016-11-03 21:24 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1305895
Environment:
Last Closed: 2016-11-03 21:24:04 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Marek Haicman 2016-02-09 09:28:21 EST
In RHEL7 version scap-workbench-1.0.2-2.el7 is the same issue.

+++ This bug was initially created as a clone of Bug #1305895 +++

Description of problem:
Specfile of scap-workbench is collectionized, but in the way that it fails if environment is collection-aware. Reason is Requires and BuildRequires fields point to collectionized version of openscap-utils package, but openscap component is NOT collectionized. Thus inevitable failure occurs.

Version-Release number of selected component (if applicable):
scap-workbench-1.1.1-1.el6

How reproducible:
reliably

Steps to Reproduce:
1. see openscap spec file
2. see scap-workbench, Requires and BuildRequires field

Actual results:
Package openscap does not use scl_ macros.
Package scap-workbench has Requirements utilizing %{?scl_prefix}

Expected results:
scap-workbench does not requires collectionized openscap


Additional information:
There is no issue with scap-workbench itself being collectionized.
Comment 5 Marek Haicman 2016-07-12 08:21:13 EDT
Version scap-workbench-1.1.2-1.el7 has scl-related entries in spec file removed.

Verified.
Comment 7 errata-xmlrpc 2016-11-03 21:24:04 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-2230.html

Note You need to log in before you can comment on or make changes to this bug.