Bug 1305917 - [RFE] Don't recreate users in undercloud installer
[RFE] Don't recreate users in undercloud installer
Status: CLOSED CURRENTRELEASE
Product: Red Hat OpenStack
Classification: Red Hat
Component: instack-undercloud (Show other bugs)
7.0 (Kilo)
Unspecified Unspecified
unspecified Severity unspecified
: ---
: 10.0 (Newton)
Assigned To: James Slagle
Shai Revivo
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-09 10:12 EST by James Slagle
Modified: 2016-10-14 12:00 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-10-14 12:00:55 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description James Slagle 2016-02-09 10:12:37 EST
The undercloud installer will recreate users on subsequent runs. We should not do this since some services record the user id on initial db setup (Heat for instance to set up the trust). When the user's are recreated, the id's change, leaving the Heat trust broken.
Comment 2 Mike Burns 2016-04-07 17:07:13 EDT
This bug did not make the OSP 8.0 release.  It is being deferred to OSP 10.
Comment 5 James Slagle 2016-10-14 12:00:55 EDT
this was fixed in OSP8

Note You need to log in before you can comment on or make changes to this bug.