Bug 1305945 - All fields in edit VM disk dialog are wrongly editable
All fields in edit VM disk dialog are wrongly editable
Status: CLOSED CURRENTRELEASE
Product: ovirt-engine
Classification: oVirt
Component: BLL.Storage (Show other bugs)
3.6.3
Unspecified Unspecified
unspecified Severity high (vote)
: ovirt-3.6.3
: 3.6.3.2
Assigned To: Tal Nisan
Elad
: Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-09 11:24 EST by mlehrer
Modified: 2016-03-10 07:47 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-03-10 07:47:46 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Storage
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
rule-engine: ovirt‑3.6.z+
rule-engine: blocker+
rule-engine: planning_ack+
tnisan: devel_ack+
rule-engine: testing_ack+


Attachments (Terms of Use)
ovirt / vdsm logs (2.42 MB, application/zip)
2016-02-09 11:24 EST, mlehrer
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 53365 master MERGED webadmin: Disk edit dialogs are all enbabled when they should not 2016-02-12 06:53 EST
oVirt gerrit 53426 ovirt-engine-3.6 MERGED webadmin: Disk edit dialogs are all enbabled when they should not 2016-02-12 12:02 EST
oVirt gerrit 53427 ovirt-engine-3.6.3 MERGED webadmin: Disk edit dialogs are all enbabled when they should not 2016-02-12 12:04 EST

  None (edit)
Description mlehrer 2016-02-09 11:24:33 EST
Created attachment 1122445 [details]
ovirt / vdsm logs

Description of problem:
Select VM disk that has Allocation Policy of thin provision.
Attempt to set to preallocated, all seems successful via the UI and Events panel.  Actual change was not successful, and VM disk remains as thin. 
Engine log reports ACTION_TYPE_FAILED_VM_IS_LOCKED
 
Version-Release number of selected component (if applicable):
ovirt-vmconsole-proxy-1.0.0-1.el6ev.noarch
libgovirt-0.3.2-1.el6.x86_64
rhevm-setup-plugin-ovirt-engine-common-3.6.2.5-0.1.el6.noarch
ovirt-engine-extension-aaa-jdbc-1.0.5-1.el6ev.noarch
ovirt-setup-lib-1.0.1-1.el6ev.noarch
rhevm-setup-plugin-ovirt-engine-3.6.2.5-0.1.el6.noarch
ovirt-host-deploy-java-1.4.1-1.el6ev.noarch
ovirt-host-deploy-1.4.1-1.el6ev.noarch
ovirt-vmconsole-1.0.0-1.el6ev.noarch

vdsm-hook-vmfex-dev-4.17.17-0.el7ev.noarch
vdsm-python-4.17.17-0.el7ev.noarch
vdsm-yajsonrpc-4.17.17-0.el7ev.noarch
vdsm-4.17.17-0.el7ev.noarch
vdsm-xmlrpc-4.17.17-0.el7ev.noarch
vdsm-jsonrpc-4.17.17-0.el7ev.noarch
vdsm-cli-4.17.17-0.el7ev.noarch
vdsm-infra-4.17.17-0.el7ev.noarch

libvirt-daemon-driver-network-1.2.17-13.el7_2.2.x86_64
libvirt-daemon-config-nwfilter-1.2.17-13.el7_2.2.x86_64
libvirt-daemon-kvm-1.2.17-13.el7_2.2.x86_64
libvirt-daemon-driver-interface-1.2.17-13.el7_2.2.x86_64
libvirt-daemon-driver-qemu-1.2.17-13.el7_2.2.x86_64
libvirt-lock-sanlock-1.2.17-13.el7_2.2.x86_64
libvirt-client-1.2.17-13.el7_2.2.x86_64
libvirt-python-1.2.17-2.el7.x86_64
libvirt-daemon-driver-storage-1.2.17-13.el7_2.2.x86_64
libvirt-daemon-driver-nwfilter-1.2.17-13.el7_2.2.x86_64
libvirt-daemon-driver-nodedev-1.2.17-13.el7_2.2.x86_64
libvirt-daemon-1.2.17-13.el7_2.2.x86_64
libvirt-daemon-driver-secret-1.2.17-13.el7_2.2.x86_64



How reproducible:
Each time

Steps to Reproduce:
1.Select Disk, and Press Edit
2.Set Allocation Policy to PreAllocated from Thin
3.Hit Ok
4.Event log shows VM X disk was updated successfully by admin

Actual results:
Editing the disk via UI after attempting to set to preallocated show it remains on thin.  The ovirt log shows the update disk failed: ACTION_TYPE_FAILED_VM_IS_LOCKED.


Expected results:
Allocation policy changed as drop down indicates, or warning that the disk update command failed.

Additional info:
Attempted with VMs that were on, or off.
Found in 3.6.2, also reproduced in separate enviroment of 3.6.3
Comment 1 Tal Nisan 2016-02-10 07:27:03 EST
The bug is not the fact that the allocation policy cannot be changed since we never supported a change in the allocation policy, the actual bug resides in the fact that fields that cannot be updated appear as changeable (Allocation Policy, Size and more).
Investigating now, but this is the actual regression here.
Comment 2 Red Hat Bugzilla Rules Engine 2016-02-10 07:37:07 EST
This bug report has Keywords: Regression or TestBlocker.
Since no regressions or test blockers are allowed between releases, it is also being identified as a blocker for this release. Please resolve ASAP.
Comment 3 Elad 2016-02-22 08:54:34 EST
The following fields are greyed out in edit disk prompt:

Size(GB)
Interface
Storage Domain
Allocation Policy

Verified using:
rhevm-3.6.3.2-0.1.el6.noarch
rhevm-webadmin-portal-3.6.3.2-0.1.el6.noarch

Note You need to log in before you can comment on or make changes to this bug.