Bug 1305947 - rpc_response_timeout not set in undercloud heat.conf
rpc_response_timeout not set in undercloud heat.conf
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-puppet-modules (Show other bugs)
7.0 (Kilo)
Unspecified Unspecified
urgent Severity high
: z4
: 7.0 (Kilo)
Assigned To: Jason Guiditta
Alexander Chuzhoy
: ZStream
Depends On:
Blocks: 1290949 1299613 1309816
  Show dependency treegraph
 
Reported: 2016-02-09 11:25 EST by Zane Bitter
Modified: 2016-12-14 10:09 EST (History)
7 users (show)

See Also:
Fixed In Version: openstack-puppet-modules-2015.1.8-50.el7ost
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-18 11:45:27 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Zane Bitter 2016-02-09 11:25:10 EST
For bug 1234153 the rpc_response_timeout for Heat in the undercloud was increased from 60s to 600s. This was confirmed to be working at the time. However, I installed an undercloud from the 2016-01-26 puddle yesterday and the value is not set:

  [cloud-user@undercloud-20160126 ~]$ sudo grep rpc_response_timeout /etc/heat/heat.conf /usr/share/heat/heat-dist.conf
  /etc/heat/heat.conf:#rpc_response_timeout = 60

Although the patch appears to still be in place:

  [cloud-user@undercloud-20160126 ~]$ grep rpc_response_timeout /usr/share/instack-undercloud/puppet-stack-config/puppet-stack-config.yaml.template 
  heat::rpc_response_timeout: 600

It looks like the patch to the puppet module has become corrupted, probably by a bad merge:

  [cloud-user@undercloud-20160126 ~]$ grep rpc_response_timeout /usr/share/openstack-puppet/modules/heat/manifests/init.pp
  # [*rpc_response_timeout*]
      'DEFAULT/rpc_response_timeout'         : value => $rpc_response_timeout;

This is missing the actual addition of $rpc_response_timeout to the heat class from the original patch: https://review.openstack.org/#/c/197964/3/manifests/init.pp


The same thing has been reported by customers using 7.2 (bug 1305557) and may be contributing to problems seen by QE in testing 7.3 (bug 1299613, bug 1302880, bug 1290949).


Installed packages:
openstack-puppet-modules-2015.1.8-47.el7ost.noarch
instack-undercloud-2.1.2-37.el7ost.noarch
Comment 7 Alexander Chuzhoy 2016-02-12 21:58:22 EST
Verified:
Environment:
openstack-puppet-modules-2015.1.8-51.el7ost.noarch

ON the undercloud node:
sudo grep ^rpc_response_timeout /etc/heat/heat.conf
rpc_response_timeout = 600
Comment 9 errata-xmlrpc 2016-02-18 11:45:27 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-0265.html
Comment 10 Zane Bitter 2016-12-14 10:09:26 EST
*** Bug 1313479 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.