Bug 1305964 - Pod pending problem without events/reasons
Pod pending problem without events/reasons
Status: CLOSED WORKSFORME
Product: OpenShift Container Platform
Classification: Red Hat
Component: Pod (Show other bugs)
3.1.0
Unspecified Unspecified
high Severity high
: ---
: ---
Assigned To: Solly Ross
DeShuai Ma
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-09 11:59 EST by Miheer Salunke
Modified: 2016-03-30 01:41 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-26 11:57:54 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 2 Andy Goldstein 2016-02-11 09:30:26 EST
Could you please post the node log file with more context? I'd like to see the following, if possible:

- Node service startup before it was restarted. This will be sometime before Feb 06 23:56:10 (beginning of attached log file)
- Node service startup after it was restarted
- Log lines around the time the pod actually started (post node service restart)
Comment 3 Miheer Salunke 2016-02-11 09:37:26 EST
Description of problem:

Without any reason we are getting multiple pods in pending state and the state never changes. 
The only solution to solve the problem was to restart the service atomic-openshift-node on the node.
It was like something on the node was blocked but we don't know what and we consider that if it was really something blocked a timeout should be implemented to avoid unlimited "pending" state on a node (other nodes were available).


The solution was to restart the atomic-openshift-node service.

Version-Release number of selected component (if applicable):
3.1.0.4

How reproducible:
At certain times, we don't know how to reproduce this problem

Steps to Reproduce:
1. At certain times, we don't know how to reproduce this problem
2.
3.

Actual results:
The pods shall run fine

Expected results:
The pods remain in pending state

Note You need to log in before you can comment on or make changes to this bug.