This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1305981 - [RHCeph 1.3.2] rgw logs in '/var/log/radosgw/
[RHCeph 1.3.2] rgw logs in '/var/log/radosgw/
Status: CLOSED ERRATA
Product: Red Hat Ceph Storage
Classification: Red Hat
Component: Installer (Show other bugs)
1.3.2
Unspecified Unspecified
unspecified Severity unspecified
: rc
: 1.3.2
Assigned To: Boris Ranto
Vasu Kulkarni
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-09 12:38 EST by Vasu Kulkarni
Modified: 2016-06-30 12:42 EDT (History)
4 users (show)

See Also:
Fixed In Version: ceph-0.94.5-9.el7cp
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-29 09:46:09 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Vasu Kulkarni 2016-02-09 12:38:32 EST
Description of problem:

rgw logs in /var/log/radosgw instead of /var/log/ceph/radosgw

From bz1303799

issues noticed by borris

2.) You do store rgw logs in '/var/log/radosgw/ceph-client.rgw.clara005.log'. We should not do that as we have designated /var/log/ceph/ directory for ceph-related logs (we do not even package /var/log/radosgw directory). Again, let me know if this is a default (not configured) behaviour somewhere in the source code so that I could update the policy accordingly.

Version-Release number of selected component (if applicable):
1.3.2 - 0.94.5-8

How reproducible:
always


Steps to Reproduce:
run test with selinux and notice the denials

Actual results:
rgw logs should be in /var/log/ceph
Comment 2 Boris Ranto 2016-02-11 06:17:00 EST
The upstream PR:

https://github.com/ceph/ceph/pull/7604

We should do the same downstream.
Comment 3 Boris Ranto 2016-02-11 09:03:50 EST
dist-git commits related to build ceph-0.94.5-9.el7cp:
http://pkgs.devel.redhat.com/cgit/rpms/ceph/commit/?h=ceph-1.3-rhel-7&id=2ceb68f2a953acc1a12b7cc7ebcc14f35cf4bc6c
Comment 6 errata-xmlrpc 2016-02-29 09:46:09 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:0313

Note You need to log in before you can comment on or make changes to this bug.