Bug 1306000 - Bison is out of date
Bison is out of date
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: bison (Show other bugs)
7.2
All Linux
unspecified Severity low
: rc
: ---
Assigned To: Patsy Franklin
Martin Cermak
Vladimír Slávik
:
Depends On:
Blocks: 1390370
  Show dependency treegraph
 
Reported: 2016-02-09 14:18 EST by Josh Marshall
Modified: 2017-08-01 14:03 EDT (History)
4 users (show)

See Also:
Fixed In Version: bison-3.0.4-1.3l7
Doc Type: Rebase: Bug Fixes and Enhancements
Doc Text:
_bison_ rebased to version 3.0.4 The _bison_ package has been upgraded to upstream version 3.0.4, which provides a number of bug fixes and enhancements: * Endless diagnostics caused by caret errors have been fixed. * The "-Werror=CATEGORY" option has been added to treat specified warnings as errors. The warnings do not have to be explicitly activated using the "-W" option. * Many improvements in handling of precedence rules and useless rules. Additionally, the following changes breaking backward compatibility have been introduced: * The following features have been deprecated: `YYFAIL`, `YYLEX_PARAM`, `YYPARSE_PARAM`, `yystype`, `yyltype` * Missing semicolons at the end of actions are no longer automatically added. * To use Bison extensions with the *autoconf* utility versions 2.69 and earlier, pass the option "-Wno-yacc" to `(AM_)YFLAGS`.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-08-01 14:03:07 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Josh Marshall 2016-02-09 14:18:53 EST
Description of problem:
Bison version appears to be on the 2.7 release line rather than the 3.0 line.


How reproducible:
N/A

Steps to Reproduce:
1.N/A
Comment 11 errata-xmlrpc 2017-08-01 14:03:07 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:1899

Note You need to log in before you can comment on or make changes to this bug.