Bug 1306002 - Failed to install unrdercloud with rhosp 8 with beta 2 director and beta 5 core
Failed to install unrdercloud with rhosp 8 with beta 2 director and beta 5 core
Status: CLOSED DUPLICATE of bug 1298189
Product: Red Hat OpenStack
Classification: Red Hat
Component: rhosp-director (Show other bugs)
8.0 (Liberty)
Unspecified Unspecified
unspecified Severity high
: ---
: 10.0 (Newton)
Assigned To: Angus Thomas
Shai Revivo
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-09 14:25 EST by bigswitch
Modified: 2016-10-14 10:34 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-10-14 10:34:45 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description bigswitch 2016-02-09 14:25:36 EST
Description of problem:
Unable to install undercloud with rhosp 8 beta 2 director and beta 5 core package

Version-Release number of selected component (if applicable):
rhosp 8

How reproducible:
100%

Steps to Reproduce:
1. Install redhat
2. Update yum
3. Install undercloud with rhosp 8 beta 2 director and beta 5 core

Actual results:
Warning: Scope(Neutron::Plugins::Ml2::Type_driver[local]): local type_driver is useful only for single-box, because it provides no connectivity between hosts
Warning: Scope(Swift::Storage::Server[6002]): The default for the mount_check parameter will change from false to true in the next release to match upstream. To disable this warning, set mount_check=false.
Warning: Scope(Swift::Storage::Server[6001]): The default for the mount_check parameter will change from false to true in the next release to match upstream. To disable this warning, set mount_check=false.
Warning: Scope(Swift::Storage::Server[6000]): The default for the mount_check parameter will change from false to true in the next release to match upstream. To disable this warning, set mount_check=false.
Error: Could not find resource 'Keystone_domain[heat_domain]' for relationship from 'Class[Keystone::Roles::Admin]' on node c5220-01
Error: Could not find resource 'Keystone_domain[heat_domain]' for relationship from 'Class[Keystone::Roles::Admin]' on node c5220-01
+ rc=1
+ set -e
+ echo 'puppet apply exited with exit code 1'
puppet apply exited with exit code 1
+ '[' 1 '!=' 2 -a 1 '!=' 0 ']'
+ exit 1
[2016-02-09 10:53:22,544] (os-refresh-config) [ERROR] during configure phase. [Command '['dib-run-parts', '/usr/libexec/os-refresh-config/configure.d']' returned non-zero exit status 1]

[2016-02-09 10:53:22,544] (os-refresh-config) [ERROR] Aborting...
Traceback (most recent call last):
  File "<string>", line 1, in <module>
  File "/usr/lib/python2.7/site-packages/instack_undercloud/undercloud.py", line 562, in install
    _run_orc(instack_env)
  File "/usr/lib/python2.7/site-packages/instack_undercloud/undercloud.py", line 494, in _run_orc
    _run_live_command(args, instack_env, 'os-refresh-config')
  File "/usr/lib/python2.7/site-packages/instack_undercloud/undercloud.py", line 325, in _run_live_command
    raise RuntimeError('%s failed. See log for details.' % name)
RuntimeError: os-refresh-config failed. See log for details.
Command 'instack-install-undercloud' returned non-zero exit status 1


Expected results:
Should be able to complete successfully

Additional info:
Comment 2 Joe Seegmiller 2016-02-19 18:22:37 EST
This is a duplicate of bug 1298189
Comment 3 Mike Burns 2016-04-07 17:07:13 EDT
This bug did not make the OSP 8.0 release.  It is being deferred to OSP 10.
Comment 5 Dmitry Tantsur 2016-10-14 10:34:45 EDT

*** This bug has been marked as a duplicate of bug 1298189 ***

Note You need to log in before you can comment on or make changes to this bug.