Bug 130602 - sgml-docbook-4.2-1.0-24.cat not owned by docbook-dtds
sgml-docbook-4.2-1.0-24.cat not owned by docbook-dtds
Status: CLOSED DUPLICATE of bug 193475
Product: Fedora
Classification: Fedora
Component: docbook-dtds (Show other bugs)
rawhide
All Linux
medium Severity low
: ---
: ---
Assigned To: Ondrej Vasik
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-08-22 12:52 EDT by W. Michael Petullo
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-05-21 03:57:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description W. Michael Petullo 2004-08-22 12:52:54 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux ppc; en-US; rv:1.7.2)
Gecko/20040809 Epiphany/1.3.5

Description of problem:
Thought the docbook-dtds package owns the symbolic links
/etc/sgml/sgml-docbook.cat and /etc/sgml/xml-docbook.cat, it does not
own the target of those links.  The files
/etc/sgml/sgml-docbook-4.2-1.0-24.cat and
/etc/sgml/xml-docbook-4.2-1.0-24.cat are not owned by any package.  At
the least, these should be %ghost'ed by docbook-dtds.

As a result of this, /etc/sgml retains out of date files following the
upgrade of the docbook-dtds package.

Version-Release number of selected component (if applicable):
docbook-dtds-1.0-24

How reproducible:
Always

Steps to Reproduce:
rpm -qf /etc/sgml/xml-docbook-4.2-1.0-24.cat

Actual Results:  file /etc/sgml/xml-docbook-4.2-1.0-24.cat is not
owned by any package

Expected Results:  The file should be owned by a package.

Additional info:
Comment 1 W. Michael Petullo 2004-08-22 12:53:33 EDT
The /etc/sgml/catalog file should also probably be %ghost'ed.
Comment 2 Tim Waugh 2004-08-23 07:29:53 EDT
This is quite fragile -- we don't want these things to be removed
after package upgrade (i.e. after the new package's %post has run).
Comment 3 Ondrej Vasik 2007-05-21 03:57:44 EDT
Closed as DUPLICATE, because in #193475 is nearly same ticket(same issue) for
newer version with suggested solution patch(although this one is disputed by Tim). 

*** This bug has been marked as a duplicate of 193475 ***

Note You need to log in before you can comment on or make changes to this bug.