This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1306042 - Cannot set Retirement date and retirement warning date for Catalog Item only in Catalog Bundle [NEEDINFO]
Cannot set Retirement date and retirement warning date for Catalog Item only ...
Status: CLOSED WONTFIX
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Automate (Show other bugs)
5.5.0
Unspecified Unspecified
medium Severity medium
: GA
: cfme-future
Assigned To: Greg McCullough
Shveta
service:catalog
:
Depends On:
Blocks: 1498600
  Show dependency treegraph
 
Reported: 2016-02-09 17:35 EST by Jared Deubel
Modified: 2017-10-04 13:43 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1498600 (view as bug list)
Environment:
Last Closed: 2017-08-28 10:46:47 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
tfitzger: needinfo? (gmccullo)
jsisul: needinfo? (gmccullo)


Attachments (Terms of Use)

  None (edit)
Description Jared Deubel 2016-02-09 17:35:30 EST
Description of problem:
Not able to set the retirement date and retirement warning date for a Catalog Item, but can for a Catalog Bundle. This should be consistent across both.

Version-Release number of selected component (if applicable):
5.5

How reproducible:
Comment 2 Greg McCullough 2016-02-11 09:47:06 EST
The retirement section on catalogs items is for the VM provision template.  A generic and orchestration catalog items would not show a retirement option since they are not derived from the provisioning dialogs.

This creates an issue on the Service side since the VM can be retired out from under the service.

I think the best option here is to hide the retirement selection on the VM provision dialog screen when displaying as part of a catalog item and add support for it from the service dialogs so it applies to the entire service.

John - Does this approach sound reasonable?
Comment 4 Tina Fitzgerald 2017-01-04 17:22:48 EST
Hi Greg,

I've heard from the field that customers provision and/or move VMs into an existing service in which case they'd have their own retirement dates. It's not unusual to want to retire only one VM from a service since customers some times use services only as a means to provision VMs and remove the service after provisioning.

We have a PR that enables users to set a retirement date for Catalog Items/Bundles and wonder if its possible that we should leave the retirement selection on the VM provision dialog.

Thanks,
Tina
Comment 6 Chris Pelland 2017-08-28 10:46:47 EDT
This bug has been open for more than a year and is assigned to an older release of CloudForms. 
If you would like to keep this Bugzilla open and if the issue is still present in the latest version of the product, please file a new Bugzilla which will be added and assigned to the latest release of CloudForms.

Note You need to log in before you can comment on or make changes to this bug.