Bug 1306048 - package ceph-installer and create systemd config to start the service and its dependencies
Summary: package ceph-installer and create systemd config to start the service and its...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Storage Console
Classification: Red Hat
Component: ceph-installer
Version: 2
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: 2
Assignee: Ken Dreyer (Red Hat)
QA Contact: Martin Bukatovic
URL:
Whiteboard:
Depends On:
Blocks: 1305198
TreeView+ depends on / blocked
 
Reported: 2016-02-09 23:20 UTC by Christina Meno
Modified: 2016-08-23 19:46 UTC (History)
7 users (show)

Fixed In Version: ceph-installer-1.0.0
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-08-23 19:46:49 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2016:1754 normal SHIPPED_LIVE New packages: Red Hat Storage Console 2.0 2017-04-18 19:09:06 UTC

Description Christina Meno 2016-02-09 23:20:48 UTC
Description of problem:
Mariner installer has changed somewhat since we did the initial packing effort

new requirements: https://github.com/ceph/mariner-installer/blob/master/setup.py#L15

enabling the service should start these

systemd support

on service start we'll need an ssh-keypair see https://bugzilla.redhat.com/show_bug.cgi?id=1305198

feel free to break this up a bit.


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 5 Ken Dreyer (Red Hat) 2016-02-16 17:43:03 UTC
Currently the daemon stuff is in a Circus template: https://github.com/ceph/ceph-installer/blob/master/deploy/playbooks/roles/common/templates/circus.ini.j2

We'll want to re-construct that in the form of individual systemd unit files.

Comment 8 Mike McCune 2016-03-28 22:51:39 UTC
This bug was accidentally moved from POST to MODIFIED via an error in automation, please see mmccune@redhat.com with any questions

Comment 15 Martin Bukatovic 2016-08-08 19:53:08 UTC
Checking ceph-installer-1.0.14-1.el7scon.noarch

~~~
# rpm -ql ceph-installer | grep systemd
/usr/lib/systemd/system-preset/80-ceph-installer.preset
/usr/lib/systemd/system/ceph-installer-celery.service
/usr/lib/systemd/system/ceph-installer.service
~~~

Ceph installer has proper systemd service unit files:

* start, stop and restart is possible
* enable/disable of the services works
* checking logs via journal works
* dependencies of ceph-installer are specified

Note that ceph-installer service is enabled by default (vendor preset).

Comment 17 errata-xmlrpc 2016-08-23 19:46:49 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2016:1754


Note You need to log in before you can comment on or make changes to this bug.