Bug 1306053 - ospd-8 puddle 2016-02-09.1 tuskar failing with (os-refresh-config) [ERROR] during post-configure phase
ospd-8 puddle 2016-02-09.1 tuskar failing with (os-refresh-config) [ERROR] du...
Status: CLOSED NOTABUG
Product: Red Hat OpenStack
Classification: Red Hat
Component: os-refresh-config (Show other bugs)
7.0 (Kilo)
Unspecified Unspecified
unspecified Severity unspecified
: ---
: 10.0 (Newton)
Assigned To: James Slagle
Shai Revivo
: Automation, AutomationBlocker
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-09 18:54 EST by Steve Linabery
Modified: 2016-10-10 00:05 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-10-10 00:05:59 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Steve Linabery 2016-02-09 18:54:27 EST
Description of problem:

tuskar based ospd install fails with stacktrace:

23:41:13 dib-run-parts Tue Feb 9 18:41:12 EST 2016 Running /usr/libexec/os-refresh-config/post-configure.d/10-tftp-iptables
23:41:13 + set -o pipefail
23:41:13 + add-rule INPUT -m udp -p udp --dport 69 -j ACCEPT
23:41:13 active
23:41:13 + add-rule INPUT -p tcp -m multiport --dports 8773,8774,8775,13773,13774,13775 -j ACCEPT
23:41:13 active
23:41:13 + add-rule INPUT -p tcp -m multiport --dports 5000,35357,13000,13357 -j ACCEPT
23:41:13 active
23:41:13 iptables-restore: line 74 failed
23:41:13 [2016-02-09 18:41:12,434] (os-refresh-config) [ERROR] during post-configure phase. [Command '['dib-run-parts', '/usr/libexec/os-refresh-config/post-configure.d']' returned non-zero exit status 1]
23:41:13 
23:41:13 [2016-02-09 18:41:12,434] (os-refresh-config) [ERROR] Aborting...
23:41:13 Traceback (most recent call last):
23:41:13   File "<string>", line 1, in <module>
23:41:13   File "/usr/lib/python2.7/site-packages/instack_undercloud/undercloud.py", line 526, in install
23:41:13     _run_orc(instack_env)
23:41:13   File "/usr/lib/python2.7/site-packages/instack_undercloud/undercloud.py", line 461, in _run_orc
23:41:13     _run_live_command(args, instack_env, 'os-refresh-config')
23:41:13   File "/usr/lib/python2.7/site-packages/instack_undercloud/undercloud.py", line 297, in _run_live_command
23:41:13     raise RuntimeError('%s failed. See log for details.', name)
23:41:13 RuntimeError: ('%s failed. See log for details.', 'os-refresh-config')
23:41:13 ERROR: openstack Command 'instack-install-undercloud' returned non-zero exit status 1
23:41:13
Comment 4 Mike Burns 2016-04-07 17:07:13 EDT
This bug did not make the OSP 8.0 release.  It is being deferred to OSP 10.
Comment 6 Jaromir Coufal 2016-10-10 00:05:59 EDT
Can't reproduce.

Note You need to log in before you can comment on or make changes to this bug.