Bug 1306064 - libgcrypt-1.7.3 is available
libgcrypt-1.7.3 is available
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: libgcrypt (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Tomas Mraz
Fedora Extras Quality Assurance
: FutureFeature, Triaged
Depends On:
Blocks: 1230986
  Show dependency treegraph
 
Reported: 2016-02-09 19:17 EST by Upstream Release Monitoring
Modified: 2016-11-28 03:07 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-11-28 03:07:41 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Rebase-helper rebase-helper-debug.log log file. See for details and report the eventual error to rebase-helper https://github.com/phracek/rebase-helper/issues. (4.88 KB, patch)
2016-04-15 12:07 EDT, Upstream Release Monitoring
no flags Details | Diff
Rebase-helper rebase-helper-debug.log log file. See for details and report the eventual error to rebase-helper https://github.com/phracek/rebase-helper/issues. (4.88 KB, patch)
2016-06-15 08:14 EDT, Upstream Release Monitoring
no flags Details | Diff
Rebase-helper rebase-helper-debug.log log file. See for details and report the eventual error to rebase-helper https://github.com/phracek/rebase-helper/issues. (4.88 KB, patch)
2016-07-14 08:18 EDT, Upstream Release Monitoring
no flags Details | Diff
Rebase-helper rebase-helper-debug.log log file. See for details and report the eventual error to rebase-helper https://github.com/phracek/rebase-helper/issues. (4.88 KB, patch)
2016-08-27 11:16 EDT, Upstream Release Monitoring
no flags Details | Diff

  None (edit)
Description Upstream Release Monitoring 2016-02-09 19:17:38 EST
Latest upstream release: 1.6.5
Current version/release in rawhide: 1.6.4-2.fc24
URL: ftp://ftp.gnupg.org/gcrypt/libgcrypt/

Please consult the package updates policy before you issue an update to a stable branch: https://fedoraproject.org/wiki/Updates_Policy

More information about the service that created this bug can be found at: https://fedoraproject.org/wiki/Upstream_release_monitoring

Please keep in mind that with any upstream change, there may also be packaging changes that need to be made. Specifically, please remember that it is your responsibility to review the new version to ensure that the licensing is still correct and that no non-free or legally problematic items have been added upstream.
Comment 1 Upstream Release Monitoring 2016-02-09 19:18:00 EST
Failed to kick off scratch build.

list index out of range
Comment 2 Upstream Release Monitoring 2016-04-15 12:06:39 EDT
Latest upstream release: 1.7.0
Current version/release in rawhide: 1.6.4-2.fc24
URL: ftp://ftp.gnupg.org/gcrypt/libgcrypt/

Please consult the package updates policy before you issue an update to a stable branch: https://fedoraproject.org/wiki/Updates_Policy

More information about the service that created this bug can be found at: https://fedoraproject.org/wiki/Upstream_release_monitoring

Please keep in mind that with any upstream change, there may also be packaging changes that need to be made. Specifically, please remember that it is your responsibility to review the new version to ensure that the licensing is still correct and that no non-free or legally problematic items have been added upstream.

Based on the information from anitya:  https://release-monitoring.org/project/1623/
Comment 3 Upstream Release Monitoring 2016-04-15 12:07:09 EDT
Patching or scratch build for libgcrypt-1.6.4 failed.
Comment 4 Upstream Release Monitoring 2016-04-15 12:07:11 EDT
Created attachment 1147706 [details]
Rebase-helper rebase-helper-debug.log log file.
See for details and report the eventual error to rebase-helper https://github.com/phracek/rebase-helper/issues.
Comment 5 Upstream Release Monitoring 2016-04-15 12:07:13 EDT
Patches were not touched. All were applied properly
Comment 6 Upstream Release Monitoring 2016-06-15 08:14:02 EDT
Latest upstream release: 1.7.1
Current version/release in rawhide: 1.6.4-2.fc24
URL: ftp://ftp.gnupg.org/gcrypt/libgcrypt/

Please consult the package updates policy before you issue an update to a stable branch: https://fedoraproject.org/wiki/Updates_Policy

More information about the service that created this bug can be found at: https://fedoraproject.org/wiki/Upstream_release_monitoring

Please keep in mind that with any upstream change, there may also be packaging changes that need to be made. Specifically, please remember that it is your responsibility to review the new version to ensure that the licensing is still correct and that no non-free or legally problematic items have been added upstream.

Based on the information from anitya:  https://release-monitoring.org/project/1623/
Comment 7 Upstream Release Monitoring 2016-06-15 08:14:35 EDT
Patching or scratch build for libgcrypt-1.6.4 failed.
Comment 8 Upstream Release Monitoring 2016-06-15 08:14:36 EDT
Created attachment 1168344 [details]
Rebase-helper rebase-helper-debug.log log file.
See for details and report the eventual error to rebase-helper https://github.com/phracek/rebase-helper/issues.
Comment 9 Upstream Release Monitoring 2016-06-15 08:14:38 EDT
Patches were not touched. All were applied properly
Comment 10 Upstream Release Monitoring 2016-07-14 08:17:52 EDT
Latest upstream release: 1.7.2
Current version/release in rawhide: 1.6.4-2.fc24
URL: ftp://ftp.gnupg.org/gcrypt/libgcrypt/

Please consult the package updates policy before you issue an update to a stable branch: https://fedoraproject.org/wiki/Updates_Policy

More information about the service that created this bug can be found at: https://fedoraproject.org/wiki/Upstream_release_monitoring

Please keep in mind that with any upstream change, there may also be packaging changes that need to be made. Specifically, please remember that it is your responsibility to review the new version to ensure that the licensing is still correct and that no non-free or legally problematic items have been added upstream.

Based on the information from anitya:  https://release-monitoring.org/project/1623/
Comment 11 Upstream Release Monitoring 2016-07-14 08:18:30 EDT
Patching or scratch build for libgcrypt-1.6.4 failed.
Comment 12 Upstream Release Monitoring 2016-07-14 08:18:32 EDT
Created attachment 1179798 [details]
Rebase-helper rebase-helper-debug.log log file.
See for details and report the eventual error to rebase-helper https://github.com/phracek/rebase-helper/issues.
Comment 13 Upstream Release Monitoring 2016-07-14 08:18:33 EDT
Patches were not touched. All were applied properly
Comment 14 Christian Stadelmann 2016-07-20 12:34:39 EDT
An update to 1.7.0 is not possible yet because it might be violating patents. See https://lists.fedoraproject.org/archives/list/security@lists.fedoraproject.org/thread/4SAZCTBFE4UHDWVNXXZLVZIUOQZNS6HJ/ for details.
Comment 15 Christian Stadelmann 2016-07-20 15:47:29 EDT
How about disabling the (possibly?) patent encumbered features with these configure flags:

--enable-ciphers=ciphers
--enable-pubkey-ciphers=ciphers
--enable-digests=digests
--enable-kfds=kdfs
Comment 16 Tomas Mraz 2016-07-21 04:29:50 EDT
They have to be also removed from the sources.
Comment 17 Upstream Release Monitoring 2016-08-27 11:16:00 EDT
Latest upstream release: 1.7.3
Current version/release in rawhide: 1.6.6-1.fc26
URL: ftp://ftp.gnupg.org/gcrypt/libgcrypt/

Please consult the package updates policy before you issue an update to a stable branch: https://fedoraproject.org/wiki/Updates_Policy

More information about the service that created this bug can be found at: https://fedoraproject.org/wiki/Upstream_release_monitoring

Please keep in mind that with any upstream change, there may also be packaging changes that need to be made. Specifically, please remember that it is your responsibility to review the new version to ensure that the licensing is still correct and that no non-free or legally problematic items have been added upstream.

Based on the information from anitya:  https://release-monitoring.org/project/1623/
Comment 18 Upstream Release Monitoring 2016-08-27 11:16:38 EDT
Patching or scratch build for libgcrypt-1.6.6 failed.
Comment 19 Upstream Release Monitoring 2016-08-27 11:16:40 EDT
Created attachment 1194886 [details]
Rebase-helper rebase-helper-debug.log log file.
See for details and report the eventual error to rebase-helper https://github.com/phracek/rebase-helper/issues.
Comment 20 Upstream Release Monitoring 2016-08-27 11:16:44 EDT
Patches were not touched. All were applied properly
Comment 21 Upstream Release Monitoring 2016-11-23 04:21:54 EST
tmraz's libgcrypt-1.7.3-1.fc26 completed http://koji.fedoraproject.org/koji/buildinfo?buildID=819762

Note You need to log in before you can comment on or make changes to this bug.