Bug 1306091 - Fix static libraries
Fix static libraries
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: mingw-pango (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Richard W.M. Jones
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-09 20:07 EST by Sandro Mani
Modified: 2016-05-13 15:01 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-05-13 15:01:19 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch (4.12 KB, application/mbox)
2016-02-09 20:07 EST, Sandro Mani
no flags Details
Patch (4.12 KB, patch)
2016-05-12 17:53 EDT, Sandro Mani
no flags Details | Diff
Patch (4.06 KB, patch)
2016-05-12 17:55 EDT, Sandro Mani
no flags Details | Diff

  None (edit)
Description Sandro Mani 2016-02-09 20:07:52 EST
Created attachment 1122601 [details]
Patch

The attached patch fixes the static shipped static libraries.

Currently they are broken due to using some public global variables with the wrong decorations, which results in undefined reference errors for i.e. g_utf8_skip.
Comment 1 Jan Kurik 2016-02-24 09:28:02 EST
This bug appears to have been reported against 'rawhide' during the Fedora 24 development cycle.
Changing version to '24'.

More information and reason for this action is here:
https://fedoraproject.org/wiki/Fedora_Program_Management/HouseKeeping/Fedora24#Rawhide_Rebase
Comment 2 Sandro Mani 2016-05-12 17:53 EDT
Created attachment 1156927 [details]
Patch

Patch rebased.
Comment 3 Sandro Mani 2016-05-12 17:55 EDT
Created attachment 1156928 [details]
Patch

(Correct patch)
Comment 4 Sandro Mani 2016-05-13 15:01:19 EDT
Uh scratch this, looks like it is not needed with newer cairos anymore.

Note You need to log in before you can comment on or make changes to this bug.