Bug 1306125 - Unable to change per page count dynamically on datastore pages
Unable to change per page count dynamically on datastore pages
Status: CLOSED ERRATA
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: UI - OPS (Show other bugs)
5.4.0
Unspecified Unspecified
medium Severity medium
: GA
: 5.6.0
Assigned To: Dávid Halász
Nandini Chandra
ui:datastore
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-10 00:01 EST by Nandini Chandra
Modified: 2016-06-29 11:37 EDT (History)
6 users (show)

See Also:
Fixed In Version: 5.6.0.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-06-29 11:37:05 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nandini Chandra 2016-02-10 00:01:08 EST
Description of problem:
-----------------------


Version-Release number of selected component (if applicable):
--------------------------
5.4.5


How reproducible:
----------------
Always


Steps to Reproduce:
-------------------
1.Perform smartstate analysis on a datastore
2.From the datastore summary page,under Content, click any link except 'All Files', for eg: 'VM Provisioned Disk Files'.
3.Try to change per page count dynamically


Actual results:
---------------
Unable to change per page count dynamically on datastore pages


Expected results:
-----------------
It should be possible to change per page count on datastore pages.


Additional info:
----------------
If you log out of the UI and log back in, the change seems to take effect.
Comment 3 Dávid Halász 2016-02-17 10:18:25 EST
Can I ask for a provider where the SmartState analysis can be triggered? I'm also comfortable with a whole database dump.
Comment 5 CFME Bot 2016-02-24 16:24:11 EST
New commit detected on ManageIQ/manageiq/master:
https://github.com/ManageIQ/manageiq/commit/83e35378e77f3c32423895e9ab7de9fccad7a04d

commit 83e35378e77f3c32423895e9ab7de9fccad7a04d
Author:     Dávid Halász <dhalasz@redhat.com>
AuthorDate: Mon Feb 22 13:14:47 2016 +0100
Commit:     Dávid Halász <dhalasz@redhat.com>
CommitDate: Tue Feb 23 09:29:47 2016 +0100

    Added missing POST route for sorting disk files
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1306124
    https://bugzilla.redhat.com/show_bug.cgi?id=1306125

 config/routes.rb                     | 1 +
 spec/routing/storage_routing_spec.rb | 3 +++
 2 files changed, 4 insertions(+)
Comment 9 errata-xmlrpc 2016-06-29 11:37:05 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1348

Note You need to log in before you can comment on or make changes to this bug.