Bug 1306135 - publican ignores the web_style: 1
publican ignores the web_style: 1
Status: CLOSED DUPLICATE of bug 1227951
Product: Publican
Classification: Community
Component: publican (Show other bugs)
future
Unspecified Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Jeff Fearn
Ruediger Landmann
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-10 01:37 EST by Elena Mishina
Modified: 2017-01-09 06:50 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-01-09 06:50:39 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Elena Mishina 2016-02-10 01:37:42 EST
Description of problem:
I'm using ALTLinux7 and have Publican4.3.2 installed. I'm trying to build a website manually but am having trouble for web_style parameters.

I was able to create to site structure using: <publican create_site>. Set parameter web_style: 1, update site.
Create home,product, version page.
When I install a book, (web_style: 1 in publican.cfg) I had warning:
Warning: Unknown config key web_style, ignoring.
The Website always shows the top menu, even if you do not specify web_style in publican.cfg
web_style: 1 doesn't work

Version-Release number of selected component (if applicable):
AltLinux, publican 4.3.2


How reproducible:
Constantly.


Steps to Reproduce:
1. Create site
2. Edit the site configuration file with web_style: 1
3. Create home, product, version page
4. Create book 
5. Edit the site configuration file with web_style: 1
6. Install book
7. Update site

Actual results:
Warning: Unknown config key web_style, ignoring.
Website hows the top menu.

Expected results:
The website resembles those produced by Publican 2, with a list of products displayed in a navigation pane at the left of the page.

Additional info:
Comment 1 Elena Mishina 2016-02-11 04:40:45 EST
Additional info:
When I use the web_style: 1 or doesn't use web_style in site_config file (parameter web_style default value 1), and install book Publican 4.3.2 creates a row in db, but doesn't show book in menu. (website includes a breadcrumb-like navigation bar across the top of the documentation, in spite of web_style=1)

if I change parameter web_style: 2, update_site -> book shows in menu.
Comment 2 Jeff Fearn 2017-01-09 06:50:39 EST
Not strictly a dupe, but purging all the web_style 1 content will address this.

*** This bug has been marked as a duplicate of bug 1227951 ***

Note You need to log in before you can comment on or make changes to this bug.