Bug 1306178 - ovirt-engine-setup-plugin-ovirt-engine does not require ovirt-engine-setup-plugin-vmconsole-proxy-helper
ovirt-engine-setup-plugin-ovirt-engine does not require ovirt-engine-setup-pl...
Status: CLOSED CURRENTRELEASE
Product: ovirt-engine
Classification: oVirt
Component: Packaging.rpm (Show other bugs)
---
Unspecified Unspecified
medium Severity medium (vote)
: ovirt-3.6.5
: 3.6.5
Assigned To: Rafael Martins
Petr Kubica
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-10 04:05 EST by Yedidyah Bar David
Modified: 2017-05-11 05:25 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-04-21 10:41:19 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Integration
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
rule-engine: ovirt‑3.6.z+
rule-engine: blocker+
ylavi: planning_ack+
sbonazzo: devel_ack+
pstehlik: testing_ack+


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 53339 master MERGED packaging: fix ovirt-engine-setup-plugin-ovirt-engine dependencies 2016-02-11 04:16 EST
oVirt gerrit 53396 ovirt-engine-3.6 MERGED packaging: fix ovirt-engine-setup-plugin-ovirt-engine dependencies 2016-02-11 09:41 EST

  None (edit)
Description Yedidyah Bar David 2016-02-10 04:05:23 EST
Description of problem:

ovirt-engine requires ovirt-engine-vmconsole-proxy-helper

ovirt-engine-vmconsole-proxy-helper requires ovirt-engine-setup-plugin-vmconsole-proxy-helper

This means that on first install of 3.6 (upgrade from 3.5, I think also clean install), user is not asked about this, because the setup-plugin is not installed yet. engine-setup installs it, and if the user then runs again the plugin will be installed and so the user will be asked.

I think ovirt-engine-setup-plugin-ovirt-engine should require ovirt-engine-setup-plugin-vmconsole-proxy-helper.

Thinking about this, it might be a good idea to also require the dwh/reports setup plugins.
Comment 1 Sandro Bonazzola 2016-02-10 04:09:39 EST
On clean install it should work fine since you install ovirt-engine and it pulls in all the dependencies.

On upgrade, ovirt-engine is under version locking so you're right, the question won't be asked on first round.
Comment 2 Nikolai Sednev 2016-02-10 07:52:24 EST
(In reply to Yedidyah Bar David from comment #0)
> Description of problem:
> 
> ovirt-engine requires ovirt-engine-vmconsole-proxy-helper
> 
> ovirt-engine-vmconsole-proxy-helper requires
> ovirt-engine-setup-plugin-vmconsole-proxy-helper
> 
> This means that on first install of 3.6 (upgrade from 3.5, I think also
> clean install), user is not asked about this, because the setup-plugin is
> not installed yet. engine-setup installs it, and if the user then runs again
> the plugin will be installed and so the user will be asked.
> 
> I think ovirt-engine-setup-plugin-ovirt-engine should require
> ovirt-engine-setup-plugin-vmconsole-proxy-helper.
> 
> Thinking about this, it might be a good idea to also require the dwh/reports
> setup plugins.

+1.
Regarding the dwh in general, it's an optional package, not required by the engine, same is for the vm-console.
I've first upgraded 3.5->3.6, onle after that I've added vm-console, then re-ran engine-setup again, while already was running on 3.6.
Comment 3 Yaniv Lavi 2016-02-10 08:54:52 EST
Why are we adding DWH and reports setup to every installation, it should be optional.
Comment 4 Sandro Bonazzola 2016-02-10 09:03:41 EST
I agree, DWH and reports are optional. Issue here is that ovirt-engine-vmconsole-proxy-helper is not.
Please ignore the DWH and reports part.

Here yum update "ovirt-engine-setup*" (as per docs) will update DWH and reports.
But the above command won't install ovirt-engine-setup-plugin-vmconsole-proxy-helper unless we add the dependency.
Comment 5 Yaniv Lavi 2016-02-10 10:57:48 EST
(In reply to Sandro Bonazzola from comment #4)
> I agree, DWH and reports are optional. Issue here is that
> ovirt-engine-vmconsole-proxy-helper is not.
> Please ignore the DWH and reports part.
> 
> Here yum update "ovirt-engine-setup*" (as per docs) will update DWH and
> reports.
> But the above command won't install
> ovirt-engine-setup-plugin-vmconsole-proxy-helper unless we add the
> dependency.

Acking just for the vm console package.
Comment 6 Petr Kubica 2016-04-15 08:22:13 EDT
Verified in 3.6.5-4 (update from latest 3.5)

#yum update rhevm-setup
Updating:
 rhevm-setup
Installing for dependencies:
 ovirt-engine-extension-aaa-jdbc
 ovirt-setup-lib
 rhevm-setup-plugin-vmconsole-proxy-helper
Updating for dependencies:
 otopi
 otopi-java
 rhevm-lib
 rhevm-setup-base
 rhevm-setup-plugin-ovirt-engine
 rhevm-setup-plugin-ovirt-engine-common
 rhevm-setup-plugin-websocket-proxy
 rhevm-setup-plugins

Note You need to log in before you can comment on or make changes to this bug.