Bug 1306190 - Python 3 support in virtualenvwrapper
Python 3 support in virtualenvwrapper
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: python-virtualenvwrapper (Show other bugs)
23
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Fedora Infrastructure SIG
Fedora Extras Quality Assurance
:
Depends On:
Blocks: PYTHON3
  Show dependency treegraph
 
Reported: 2016-02-10 04:34 EST by Jan Včelák
Modified: 2016-07-26 05:45 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-07-25 20:42:15 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Specfile patch for python2/3 subpackages support (4.67 KB, patch)
2016-06-28 09:51 EDT, Lumír Balhar
no flags Details | Diff
New patch version (4.73 KB, patch)
2016-07-25 04:34 EDT, Lumír Balhar
no flags Details | Diff

  None (edit)
Description Jan Včelák 2016-02-10 04:34:57 EST
Description of problem:

According to the upstream project web site, virtualenvwrapper should support Python 3 [1]. Since Python 3 is default in Fedora, the package should default to Python 3 as well.

[1] https://pypi.python.org/pypi/virtualenvwrapper/#python-versions

Version-Release number of selected component (if applicable):
python-virtualenvwrapper-4.6.0-1.fc23.noarch

How reproducible:
always

Steps to Reproduce:
1. dnf install python3-virtualenvwrapper
2.
3.

Actual results:
No package python3-virtualenvwrapper available.

Expected results:


Additional info:
Comment 1 Fedora Admin XMLRPC Client 2016-04-04 16:37:28 EDT
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 2 Lumír Balhar 2016-06-28 09:51 EDT
Created attachment 1173456 [details]
Specfile patch for python2/3 subpackages support

Hello.

I am providing the patch for python2/3 subpackages. Could you please do the update?

Koji scratch build: http://koji.fedoraproject.org/koji/taskinfo?taskID=14688988

Thank you and have a nice day.
Lumir
Comment 3 Lumír Balhar 2016-07-18 05:43:18 EDT
Hello.

If maintainer has nothing against then we can push this change in few days.

Have a nice day.
Lumir
Comment 4 Kevin Fenzi 2016-07-22 18:59:36 EDT
Can you rebase the patch (It doesn't apply cleanly as there have been several changes since you made it in the package). 

Otherwise it looks ok to me...
Comment 5 Lumír Balhar 2016-07-25 04:34 EDT
Created attachment 1183630 [details]
New patch version

Hello.

I am providing rebased patch. Successful Koji build: https://koji.fedoraproject.org/koji/taskinfo?taskID=15012052

Have a nice day.
Lumir
Comment 6 Kevin Fenzi 2016-07-25 20:42:15 EDT
Applied and built in rawhide, thanks!

Note You need to log in before you can comment on or make changes to this bug.