Bug 1306193 - cd to .snaps fails with "transport endpoint not connected" after force start of the volume.
cd to .snaps fails with "transport endpoint not connected" after force start ...
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: snapshot (Show other bugs)
mainline
All Linux
unspecified Severity high
: ---
: ---
Assigned To: Avra Sengupta
: ZStream
Depends On: 1305849
Blocks: 1309233
  Show dependency treegraph
 
Reported: 2016-02-10 04:38 EST by Avra Sengupta
Modified: 2016-06-16 09:57 EDT (History)
5 users (show)

See Also:
Fixed In Version: glusterfs-3.8rc2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1305849
: 1309233 (view as bug list)
Environment:
Last Closed: 2016-06-16 09:57:06 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 1 Vijay Bellur 2016-02-10 04:48:14 EST
REVIEW: http://review.gluster.org/13420 (glusterd/snapshot : Remove stale pmap registry entry) posted (#1) for review on master by Avra Sengupta (asengupt@redhat.com)
Comment 2 Vijay Bellur 2016-02-17 03:52:51 EST
COMMIT: http://review.gluster.org/13420 committed in master by Rajesh Joseph (rjoseph@redhat.com) 
------
commit bfe689d25ecde567a90135b47f31b89d7714aaf4
Author: Avra Sengupta <asengupt@redhat.com>
Date:   Wed Feb 10 15:02:48 2016 +0530

    glusterd/snapshot : Remove stale pmap registry entry
    
    Perform a pmap_registry_remove on a stale registry
    entry from the previous run of snapd, which makes the
    query callback always return the older port number.
    
    Change-Id: I7fc504d2b09d32a9c945ec2c33e0e092a0d186ec
    BUG: 1306193
    Signed-off-by: Avra Sengupta <asengupt@redhat.com>
    Reviewed-on: http://review.gluster.org/13420
    Smoke: Gluster Build System <jenkins@build.gluster.com>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Rajesh Joseph <rjoseph@redhat.com>
Comment 3 Niels de Vos 2016-06-16 09:57:06 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.0, please open a new bug report.

glusterfs-3.8.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://blog.gluster.org/2016/06/glusterfs-3-8-released/
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.