Bug 1306199 - gluster volume heal info takes extra 2 seconds
gluster volume heal info takes extra 2 seconds
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: replicate (Show other bugs)
mainline
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Pranith Kumar K
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-10 05:09 EST by Pranith Kumar K
Modified: 2016-06-16 09:57 EDT (History)
2 users (show)

See Also:
Fixed In Version: glusterfs-3.8rc2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1306738 (view as bug list)
Environment:
Last Closed: 2016-06-16 09:57:06 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pranith Kumar K 2016-02-10 05:09:36 EST
Description of problem:
This is a code review bug, where there is a 2 second sleep in the code which is un-necessary.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 1 Vijay Bellur 2016-02-10 05:09:55 EST
REVIEW: http://review.gluster.org/13421 (heal: Remove sleep()) posted (#1) for review on master by Pranith Kumar Karampuri (pkarampu@redhat.com)
Comment 2 Vijay Bellur 2016-02-10 21:25:21 EST
REVIEW: http://review.gluster.org/13421 (heal: Remove sleep()) posted (#2) for review on master by Pranith Kumar Karampuri (pkarampu@redhat.com)
Comment 3 Vijay Bellur 2016-02-11 12:05:51 EST
COMMIT: http://review.gluster.org/13421 committed in master by Pranith Kumar Karampuri (pkarampu@redhat.com) 
------
commit 320779d53ae013147d5e2556d2946c73e45734ab
Author: Pranith Kumar K <pkarampu@redhat.com>
Date:   Wed Feb 10 15:28:39 2016 +0530

    heal: Remove sleep()
    
    I wrote this program from a sample gfapi program which had sleep.
    I am not sure why this sleep was needed. So removing it now.
    
    Changed tests/bugs/replicate/bug-1190069-afr-stale-index-entries.t
    to execute count_sh_entries every second, instead of comparing
    same value over and over.
    
    Change-Id: I7b89d6cab3e50bb7bf4d40a6064f2d8734155bea
    BUG: 1306199
    Signed-off-by: Pranith Kumar K <pkarampu@redhat.com>
    Reviewed-on: http://review.gluster.org/13421
    Smoke: Gluster Build System <jenkins@build.gluster.com>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Krutika Dhananjay <kdhananj@redhat.com>
Comment 4 Niels de Vos 2016-06-16 09:57:06 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.0, please open a new bug report.

glusterfs-3.8.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://blog.gluster.org/2016/06/glusterfs-3-8-released/
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.