This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 130620 - tvtime fails as user since 20040821
tvtime fails as user since 20040821
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: initscripts (Show other bugs)
3
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
:
Depends On:
Blocks: FC3Target
  Show dependency treegraph
 
Reported: 2004-08-22 17:34 EDT by shrek-m
Modified: 2014-03-16 22:47 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-08-27 10:08:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description shrek-m 2004-08-22 17:34:26 EDT
Description of problem:
# grep initscripts /var/log/yum.log
08/19/04 17:20:05 Updated: initscripts 7.62-1.i386
08/21/04 10:52:04 Updated: initscripts 7.64-1.i386
08/21/04 16:47:49 Updated: initscripts 7.66-1.i386

the problem exist since 20040821,
i did not reboot between the updates 7.64/7.66

some modules in /etc/modprobe.conf are not loaded while booting.
eg. bttv, snd-es1938, fdomain

result: starting tvtime fails as user.

as root:
# modprobe bttv
# modprobe snd-es1938
# tvtime

all is ok as root but not as user

after logout and new login as user
tvtime works now as user

Version-Release number of selected component (if applicable):
initscripts-7.64-1 ?
initscripts-7.66-1 !

How reproducible:
Always

Steps to Reproduce:
1. boot into kernel >= 2.6.8-1.525
2. login as user
3. start tvtime
    

Actual Results:  tvtime fails as user

Expected Results:  all modules should be loaded while booting like
expected

Additional info:

this problem exist only with kernel >= 2.6.8-1.525
booting into <= 2.6.8-1.525  all is ok!

# rpm -qa kernel | sort
kernel-2.6.7-1.478
kernel-2.6.7-1.517
kernel-2.6.8-1.524
kernel-2.6.8-1.525
kernel-2.6.8-1.526
Comment 1 Bill Nottingham 2004-08-23 15:17:45 EDT
This is more likely to be due to udev than anyting else.
Comment 2 shrek-m 2004-08-27 10:08:42 EDT
thanks,
the last updates did not solved the problem,
seems to be ok now with todays rawhide-updates 20040827

$ rpm -q kernel udev initscripts mkinitrd
kernel-2.6.7-1.478
kernel-2.6.7-1.517
kernel-2.6.8-1.524
kernel-2.6.8-1.525
kernel-2.6.8-1.526
udev-030-7
initscripts-7.68-1
initscripts-7.70-1
mkinitrd-4.1.4-1
mkinitrd-4.1.6-1
Comment 3 Bill Nottingham 2004-08-27 11:57:10 EDT
initscripts-7.70 now loads modules on bootup; that's where the fix is
(most likely).

Note You need to log in before you can comment on or make changes to this bug.