Bug 1306226 - 7kaa: FTBFS in rawhide on armhfp
7kaa: FTBFS in rawhide on armhfp
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: 7kaa (Show other bugs)
rawhide
armhfp Linux
unspecified Severity high
: ---
: ---
Assigned To: Ding-Yi Chen
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F24FTBFS 1291126 1291128
  Show dependency treegraph
 
Reported: 2016-02-10 06:05 EST by Fedora Release Engineering
Modified: 2016-03-08 04:06 EST (History)
3 users (show)

See Also:
Fixed In Version: 7kaa-2.14.5-12.fc24
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-03-07 21:38:17 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
build.log (324.67 KB, text/plain)
2016-02-10 06:05 EST, Fedora Release Engineering
no flags Details
root.log (108.32 KB, text/plain)
2016-02-10 06:05 EST, Fedora Release Engineering
no flags Details
state.log (617 bytes, text/plain)
2016-02-10 06:05 EST, Fedora Release Engineering
no flags Details

  None (edit)
Description Fedora Release Engineering 2016-02-10 06:05:29 EST
Your package 7kaa failed to build from source in current rawhide.

http://koji.fedoraproject.org/koji/taskinfo?taskID=12803957

For details on mass rebuild see https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
Comment 1 Fedora Release Engineering 2016-02-10 06:05:32 EST
Created attachment 1122748 [details]
build.log
Comment 2 Fedora Release Engineering 2016-02-10 06:05:34 EST
Created attachment 1122749 [details]
root.log
Comment 3 Fedora Release Engineering 2016-02-10 06:05:35 EST
Created attachment 1122750 [details]
state.log
Comment 4 Raphael Groner 2016-02-10 06:31:08 EST
OBULLET.cpp: At global scope:
OBULLET.cpp:41:78: error: narrowing conversion of '-1' from 'int' to 'char' inside { } [-Wnarrowing]
  { 0, 0,-1, 0, 1,-1,-1, 1, 1, 0,-2, 0, 2, -1,-2,-2,-1, 1, 2, 2, 1,-2,-2, 2, 2};

That's cause gcc6 enforces you to use 'signed int' instead of just 'int' as the variable type. We've seen that already in dreamchess-tools, psi and iris packages. A patch should be easy to do and upstreamable.
Comment 5 Raphael Groner 2016-02-13 16:56:22 EST
Odd. I can not reproduce locally for f24 with fedpkg mockbuild, but fedpkg scratch-build fails on koji.
Comment 6 Kevin Kofler 2016-02-13 18:50:13 EST
> That's cause gcc6 enforces you to use 'signed int' instead of just 'int' as the
> variable type.

signed char actually. int is always signed. char can be signed or unsigned depending on the platform. On ARM, it defaults to unsigned. (You can use the -fsigned-char switch to force it to be signed, but the code should use "signed char" explicitly for maximum portability.) This previously compiled without error, but did not necessarily work right, because -1 was silently converted to 255 on ARM.
Comment 7 Raphael Groner 2016-02-15 16:07:32 EST
We need a proper upstream(able) patch. Unfortunately, I do not see reasonable spare time to do that by myself in the near future.
Comment 8 Jan Kurik 2016-02-24 10:33:59 EST
This bug appears to have been reported against 'rawhide' during the Fedora 24 development cycle.
Changing version to '24'.

More information and reason for this action is here:
https://fedoraproject.org/wiki/Fedora_Program_Management/HouseKeeping/Fedora24#Rawhide_Rebase
Comment 9 Raphael Groner 2016-02-27 12:56:28 EST
Still b0rken. Maintainer, please urgently give any feedback or orphan this package.

It would be really sad to see this great game go away again in Fedora, I'm wondering why I did the package review recently (for you) and you can not actively care any more about package consistency as it's required by package maintainer responsibilities in our guidelines.
Comment 10 Ding-Yi Chen 2016-02-28 18:15:45 EST
I intended to fix it around later this week or early next week.
Comment 11 Raphael Groner 2016-03-04 11:10:47 EST
Friendly reminder (again). Please notice the awareness of FeSCo and take care to not get the package orphaned.
Comment 12 Upstream Release Monitoring 2016-03-07 20:37:16 EST
yselkowitz's 7kaa-2.14.5-12.fc25 completed http://koji.fedoraproject.org/koji/buildinfo?buildID=742816
Comment 13 Yaakov Selkowitz 2016-03-07 21:38:17 EST
The assumption that char is signed exists throughout the code.  A patch fixing all such occurrences would be quite extensive.  As a leaf package, building with -fsigned-char is the simplest solution.
Comment 14 Raphael Groner 2016-03-08 03:08:29 EST
Wouldn't it be better to request from upstream the general change to unsigned char?
Comment 15 Yaakov Selkowitz 2016-03-08 03:12:05 EST
(In reply to Raphael Groner from comment #14)
> Wouldn't it be better to request from upstream the general change to
> unsigned char?

signed char is fine, it just needs to be explicit.  Feel free to work with upstream for a fix in the code itself, but I looked into this and the changes would be extensive.
Comment 16 Raphael Groner 2016-03-08 03:16:13 EST
(In reply to Yaakov Selkowitz from comment #15)
> (In reply to Raphael Groner from comment #14)
> > Wouldn't it be better to request from upstream the general change to
> > unsigned char?
> 
> signed char is fine, it just needs to be explicit.  Feel free to work with
> upstream for a fix in the code itself, but I looked into this and the
> changes would be extensive.

Ack. Besides the fact many upstreams do not care that much about ARM as an important platform to develop on, especially in gaming sector (my experience so far).
Comment 17 Raphael Groner 2016-03-08 04:06:04 EST
Overseen you built for f24 as well, sorry.

Note You need to log in before you can comment on or make changes to this bug.