Bug 1306260 - [gnome-shell] dimensions are not displayed when resizing gnome-terminal in a GNOME on Xorg session
[gnome-shell] dimensions are not displayed when resizing gnome-terminal in a ...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: gnome-shell (Show other bugs)
24
x86_64 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Owen Taylor
Fedora Extras Quality Assurance
:
: 1350506 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-10 07:37 EST by Joachim Frieben
Modified: 2017-03-26 03:29 EDT (History)
7 users (show)

See Also:
Fixed In Version: gnome-shell-3.20.4-3.fc24
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-02-01 16:49:20 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Joachim Frieben 2016-02-10 07:37:43 EST
Description of problem:
When resizing a gnome-terminal window in a GNOME on Xorg session, the familiar tooltip in the center of the window which displays the window dimensions is missing.

Version-Release number of selected component (if applicable):
gnome-shell-3.19.4-2.fc24

How reproducible:
Always.

Steps to Reproduce:
1. Launch GNOME on Xorg session.
2. Launch gnome-terminal.
3. Resize terminal window.

Actual results:
Window gets resized but no window dimensions are displayed.

Expected results:
Window gets resized and window dimensions are displayed.

Additional info:
1. The tooltip is displayed correctly for current Fedora 23.
2. Installed packages include xorg-x11-server-Xorg-1.18.1-1.fc24.
Comment 1 Jan Kurik 2016-02-24 09:28:30 EST
This bug appears to have been reported against 'rawhide' during the Fedora 24 development cycle.
Changing version to '24'.

More information and reason for this action is here:
https://fedoraproject.org/wiki/Fedora_Program_Management/HouseKeeping/Fedora24#Rawhide_Rebase
Comment 2 H.J. Lu 2016-06-27 12:49:07 EDT
*** Bug 1350506 has been marked as a duplicate of this bug. ***
Comment 3 Joel Uckelman 2016-07-28 19:23:27 EDT
I'm seeing this on F24 with all windows, not just gnome-terminal.
Comment 4 Joel Uckelman 2016-07-29 07:25:51 EDT
Partial duplicate of Bug 1349688.
Comment 5 Joel Uckelman 2016-07-29 07:30:07 EDT
Presently, I have two F24 systems which I upgraded from F22. In F22, I got correct dimensions displayed for all windows when resizing, on both systems. (gnome-terminal and gvim showed columns and rows, everything else showed width and height in pixels.)

What I have after upgrading to F24 is one system where I get no dimensions tooltip for anything, and one system where I still get the dimensions tooltips, but for gnome-terminal the dimensions are now in pixels.

I'd love to help troubleshoot this so we can get it fixed. Please let me know what information is needed.
Comment 6 H.J. Lu 2017-02-01 16:49:20 EST
It is caused by Wayland.  After changing /etc/gdm/custom.conf to use
Xorg:

[daemon]
# Uncoment the line below to force the login screen to use Xorg
WaylandEnable=false

I got back the geometry when resizing.

*** This bug has been marked as a duplicate of bug 1269097 ***
Comment 7 Joachim Frieben 2017-02-02 05:02:03 EST
(In reply to H.J. Lu from comment #6)
Issue appears to have been resolved for both of current Fedora 24 and Fedora 25 with the standard setup of GDM (running on top of Wayland). I have checked for Fedora 24 running inside a virtual machine: 
- window geometry is shown when choosing GNOME on Xorg session.
- window geometry is not shown  GNOME (on Wayland) session.
For Fedora 25, the issue is gone both when running on bare metal and inside a virtual machine.
Comment 8 Brad Bell 2017-03-24 11:09:12 EDT
I am not sure if this is the same bug, but it appears to be closely related:

Using Fedora 25:
cppad_mixed.git>uname -a
Linux localhost.localdomain 4.9.14-200.fc25.x86_64 #1 SMP Mon Mar 13 19:26:40 UTC 2017 x86_64 x86_64 x86_64 GNU/Linux
when I resize a gnome terminal window it does not display the window size in characters during the resize operation.

When I use Fedora 23:
~>uname -a
Linux brad-home 4.7.5-100.fc23.x86_64 #1 SMP Mon Sep 26 19:29:03 UTC 2016 x86_64 x86_64 x86_64 GNU/Linux
and I resize a terminal window, the size of the window in characters is displayed in the center of the widow during the resize operation

P.S.
I am using a virtual machine for both of these tests.
Comment 9 Joachim Frieben 2017-03-24 16:42:39 EDT
(In reply to Brad Bell from comment #8)
Please make sure that you run a GNOME on Xorg session under Fedora 25. The default session type is GNOME on Wayland now.
Comment 10 Brad Bell 2017-03-25 06:11:12 EDT
Selecting the gear icon on the login screen, and then Xorg, worked. Thanks.
Comment 11 Joachim Frieben 2017-03-26 03:29:45 EDT
(In reply to Brad Bell from comment #10)
Here, things work as expected both under Fedora 25 and Fedora 26. To make sure that your actual session type is really "GNOME on Xorg", verify that your environment satisfies DESKTOP_SESSION=gnome-xorg, thanks.

Note You need to log in before you can comment on or make changes to this bug.