Bug 1306263 - Normalize policy unit weights
Normalize policy unit weights
Status: CLOSED CURRENTRELEASE
Product: ovirt-engine
Classification: oVirt
Component: Backend.Core (Show other bugs)
4.0.0
Unspecified Unspecified
unspecified Severity medium (vote)
: ovirt-4.1.0-beta
: 4.1.0.2
Assigned To: Martin Sivák
Artyom
http://www.ovirt.org/develop/release-...
: Triaged
Depends On:
Blocks: 1207255 1392393 1404660
  Show dependency treegraph
 
Reported: 2016-02-10 07:39 EST by Martin Sivák
Modified: 2017-03-28 01:34 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
The weighting for virtual machine scheduling has been updated. The best host for the virtual machine is now selected using a weighted rank algorithm instead of the pure sum of weights. A rank is calculated for the policy unit and host, and the weight multiplier is then used to multiply the ranks for the given policy unit. The host with the highest number is selected. The reason for the change is that current weight policy units do not use a common result value range. Each unit reports numbers as needed, and this causes issues with user configured preferences. For example, memory (which has high numbers) always wins over CPU (0-100). This update ensures that the impact of the policy unit multiplier for the scheduling policy configuration is more predictable. However, users that are using it should check their configuration for sanity when upgrading.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-02-01 09:45:15 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: SLA
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
rule-engine: ovirt‑4.1+
bmcclain: priority_rfe_tracking+
rule-engine: planning_ack+
msivak: devel_ack+
mavital: testing_ack+


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 67707 master MERGED scheduling: Switch to rank based policy unit weight normalization 2016-12-05 08:57 EST

  None (edit)
Description Martin Sivák 2016-02-10 07:39:44 EST
Description of problem:

Each policy unit uses a different scale for weight. That means factors are almost unusable because weight 1 (affinity group violation) will be always overridden by weight 500 (memory in MiB) even when the factor is for example a 100.

Version-Release number of selected component (if applicable):

iirc 3.1 till now
Comment 1 Sandro Bonazzola 2016-05-02 05:58:13 EDT
Moving from 4.0 alpha to 4.0 beta since 4.0 alpha has been already released and bug is not ON_QA.
Comment 2 Yaniv Lavi 2016-05-23 09:19:09 EDT
oVirt 4.0 beta has been released, moving to RC milestone.
Comment 3 Yaniv Lavi 2016-05-23 09:26:44 EDT
oVirt 4.0 beta has been released, moving to RC milestone.
Comment 4 Martin Sivák 2016-07-13 05:42:12 EDT
All support for this is present in the code for unit testing purposes, but we do not want to enable this for 4.0 as it will slightly change the scheduler behaviour. The plan is to enable normalization (using rank atm) for 4.1 and making sure all test plans are updated and QE is aware of this change.
Comment 6 Artyom 2017-01-03 11:19:39 EST
Verified on rhevm-4.1.0-0.3.beta2.el7.noarch

Tested:
1) Weight modules factors
2) Weight modules ranks
3) Weight modules:
     VmAffinityGroups
     OptimalForCpuEvenDistribution
     VmToHostsAffinityGroups
     OptimalForMemoryEvenDistribution
     PreferredHosts
     OptimalForCpuPowerSaving
     OptimalForMemoryPowerSaving

Note You need to log in before you can comment on or make changes to this bug.