Bug 1306272 - nano seg-faults when NO replied to file lock conflict
nano seg-faults when NO replied to file lock conflict
Status: CLOSED DUPLICATE of bug 1306413
Product: Fedora
Classification: Fedora
Component: nano (Show other bugs)
x86_64 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Kamil Dudka
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2016-02-10 08:05 EST by Don Swaner
Modified: 2016-02-10 14:21 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2016-02-10 14:21:43 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Don Swaner 2016-02-10 08:05:02 EST
Description of problem:
When 2 nano sessions attempt to edit the same file, and the file locking prompt is displayed, when "NO" is entered, nano seg-faults

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. edit an existing file with nano (with "set locking" in .nanorc)
2. in a second nano session, attempt to edit the same file
3. reply 'N' to the file locking prompt

Actual results:
nano seg-faults

Expected results:
nano gracefully terminates the second attempted edit of the file.

Additional info:
Comment 1 Kamil Dudka 2016-02-10 12:18:39 EST
I am not able to reproduce the crash locally.  Could you please attach a backtrace or coredump from the crash?
Comment 2 Don Swaner 2016-02-10 14:13:06 EST
See BUG 1306413 for the backtrace.  Sorry for the inconvenience of the duplicate BUG report, but a SELINUX issue is complicating matters at this end, and my MATE automatic bug reporting tool didn't find BUG 1306272 for some reason.
Comment 3 Kamil Dudka 2016-02-10 14:21:43 EST

*** This bug has been marked as a duplicate of bug 1306413 ***

Note You need to log in before you can comment on or make changes to this bug.