This service will be undergoing maintenance at 20:00 UTC, 2017-04-03. It is expected to last about 30 minutes
Bug 130629 - initlog returns spurious error status when starting certain daemons
initlog returns spurious error status when starting certain daemons
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: initscripts (Show other bugs)
2
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
Brock Organ
http://gpsd.berlios.de/
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-08-22 23:45 EDT by Eric Raymond
Modified: 2014-03-16 22:47 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-03-31 16:51:36 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Eric Raymond 2004-08-22 23:45:27 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040510

Description of problem:
While crafting init scripts for gpsd-2, I found that initlog 
consistently returns a spurious nonzero status when starting up 
gpsd.  The result is that the daemon function displays a FAILED
indication even though daemon startup was successful.




Version-Release number of selected component (if applicable):
initscripts-7.55.1

How reproducible:
Always

Steps to Reproduce:
1. Download and build gpsd from http://gpsd.berlios.de/
2. Run "initlog -q -c 'qpsd'; echo $?" as root.
3. Observe that the return status is nonzero.
4. Verify with ps ax that gpsd is running
    

Actual Results:  The daemon function spuriously indicated failure.


Expected Results:  A big green SUCCEEDED.


Additional info:

I am almost certain this symptom is related to bug #67232.  gpsd
forks itself after it starts up.  I compiled initscripts from 
current CVS HEAD, went in with gdb, and verified that the problem does
indeed appear to be in the waitpid() call in monitor().

Fix the damn SIGCHLD problem already.  Alan Cox diagnosed this one
two years ago.
Comment 1 Bill Nottingham 2005-03-31 16:51:36 EST
Can't reproduce this on a current release. Note that initlog is deprecated and
will be removed from future releases.

Note You need to log in before you can comment on or make changes to this bug.