This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1306296 - ps2pdf fails Error: /invalidfont in /findfont -- evince throws invalidfont -10
ps2pdf fails Error: /invalidfont in /findfont -- evince throws invalidfont -10
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: ghostscript (Show other bugs)
7.2
Unspecified Unspecified
high Severity medium
: rc
: ---
Assigned To: David Kaspar [Dee'Kej]
QE Internationalization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-10 08:40 EST by Brandon Ingalls
Modified: 2016-10-25 12:19 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-10-25 12:19:51 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
strace -eopen of the ps2pdf command. (123.78 KB, text/plain)
2016-02-10 08:40 EST, Brandon Ingalls
no flags Details

  None (edit)
Description Brandon Ingalls 2016-02-10 08:40:13 EST
Created attachment 1122790 [details]
strace -eopen of the ps2pdf command.

Description of problem:
Many ps files are unusable on RHEL 7, our users are unable to convert from ps to pdf as the application fails with...
``` http://accelconf.web.cern.ch/accelconf/jacow/templates/sample.ps
[blingall-t@guardian ~]$ ps2pdf sample.ps 
Error: /invalidfont in /findfont
Operand stack:
   Fa   107   --nostringval--   33   33   25   --nostringval--   37   1   --nostringval--   54   1   --nostringval--   37   21   29   25   1   --nostringval--   37   37   37   58   21   2   --nostringval--   21   37   37   1   --nostringval--   33   37   2   --nostringval--   33   3   --nostringval--   25   1   --nostringval--   25   3   --nostringval--   71   54   2   --nostringval--   42   2   --nostringval--   42   54   54   66   2   --nostringval--   29   25   3   --nostringval--   46   54   50   1   --nostringval--   54   6   --nostringval--   21   37   1   --nostringval--   37   37   37   1   --nostringval--   37   37   37   1   --nostringval--   21   19   1   --nostringval--   19   2   --nostringval--   25   25   25   39   --nostringval--   --nostringval--   48   74.7198   Times-Roman
Execution stack:
   %interp_exit   .runexec2   --nostringval--   --nostringval--   --nostringval--   2   %stopped_push   --nostringval--   --nostringval--   --nostringval--   false   1   %stopped_push   1884   1   3   %oparray_pop   1883   1   3   %oparray_pop   1867   1   3   %oparray_pop   1755   1   3   %oparray_pop   --nostringval--   %errorexec_pop   .runexec2   --nostringval--   --nostringval--   --nostringval--   2   %stopped_push   --nostringval--   --nostringval--   1836   99   4   %oparray_pop
Dictionary stack:
   --dict:1167/1684(ro)(G)--   --dict:0/20(G)--   --dict:79/200(L)--   --dict:113/300(L)--
Current allocation mode is local
Last OS error: No such file or directory
Current file position is 49762
GPL Ghostscript 9.07: Unrecoverable error, exit code 1
```

Attempting to view a ps file with evince often results in
```
invalidfont -10
Segmentation fault
```

Version-Release number of selected component (if applicable):
ghostscript-9.07-18.el7.x86_64


How reproducible:
Very

Steps to Reproduce:
1. Download http://accelconf.web.cern.ch/accelconf/jacow/templates/sample.ps
2. Run `ps2pdf sample.ps`
3. Attempt to open the sample ps file with Evince `evince sample.ps`

Actual results:
Errors and a Segfault

Expected results:
The ability to work with ps files.


Additional info:
Comment 2 David Kaspar [Dee'Kej] 2016-07-04 10:23:29 EDT
Hello Brandon,

thank you for your report. I have looked into the strace you have provided in your attachement 1122790, and I can see that you or your customer are using 'freetype-infinality'.

> open("/usr/lib64/freetype-infinality/libfreetype.so.6", O_RDONLY|O_CLOEXEC) = 3

Using 3rd party shared libraries that modify the behaviour of RHEL product in any way is not supported by Red Hat.

From what I was able to lookup I see that 'freetype-infidelity' modifies the way the fonts are rendered on Linux OS. Searching more on the Internet I also found out that this software tends to have many problems/issues/bugs.

AFAIK, 'ghostscript' is continuosly evolving and upstream is working on hardening it, but it still might prone to crashing if some assumptions made by upstream are not met. In this case it would be some assumptions about "format" of the fonts. If they are modified in any way, Red Hat can't guarantee ghostscript's functionality, nor any other product relying on fonts.

I have tried to reproduce this issue on RHEL-7.2 in several ways, but I was not successful. Versions of packages used:
- ghostscript-9.07-18.el7.x86_64
- lcms2-2.6-2.el7.x86_64

If you can, please, provide us with some reproducer which does not use the 'freetype-infinality' shared library. Otherwise, I will close this bug in the future.

Thank you for your understanding.

Best regards,

David
Comment 3 David Kaspar [Dee'Kej] 2016-10-25 12:19:33 EDT
The reporter of this BZ is not responding. Therefore, I'm closing this BZ, because from the strace we can see that 3rd party library was used, which is not supported by Red Hat.

In case anyone stumble upon this issue (without 'freetype-infinality', please, feel free to reopen this BZ.

David

Note You need to log in before you can comment on or make changes to this bug.