Bug 1306301 - Hosted engine setup fails after first failed installation (workaround: remove empty /etc/pki/vdsm/libvirt-spice/server-cert.pem)
Hosted engine setup fails after first failed installation (workaround: remove...
Status: CLOSED DUPLICATE of bug 1001181
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-hosted-engine-setup (Show other bugs)
Unspecified Unspecified
unspecified Severity medium
: ovirt-3.6.5
: ---
Assigned To: Simone Tiraboschi
Ilanit Stein
Depends On:
  Show dependency treegraph
Reported: 2016-02-10 09:00 EST by Roman Hodain
Modified: 2016-03-22 09:29 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2016-03-22 09:29:48 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: Integration
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Roman Hodain 2016-02-10 09:00:29 EST
Description of problem:
When the hoseted-engine --deploy fails on RHEV-H the second attempt to configure the hosted engine always fails with the following ERROR:

2016-02-10 10:40:55 DEBUG otopi.plugins.ovirt_hosted_engine_setup.pki.vdsmpki plugin.execute:932 execute-output: ('/bin/openssl', 'x50
9', '-noout', '-text', '-in', '/etc/pki/vdsm/libvirt-spice/server-cert.pem') stdout:

2016-02-10 10:40:55 DEBUG otopi.plugins.ovirt_hosted_engine_setup.pki.vdsmpki plugin.execute:937 execute-output: ('/bin/openssl', 'x50
9', '-noout', '-text', '-in', '/etc/pki/vdsm/libvirt-spice/server-cert.pem') stderr:
unable to load certificate
140287306053536:error:0906D06C:PEM routines:PEM_read_bio:no start line:pem_lib.c:703:Expecting: TRUSTED CERTIFICATE

2016-02-10 10:40:55 DEBUG otopi.context context._executeMethod:152 method exception
Traceback (most recent call last):
  File "/usr/lib/python2.7/site-packages/otopi/context.py", line 142, in _executeMethod
  File "/usr/share/ovirt-hosted-engine-setup/plugins/ovirt-hosted-engine-setup/pki/vdsmpki.py", line 281, in _late_setup
  File "/usr/share/ovirt-hosted-engine-setup/plugins/ovirt-hosted-engine-setup/pki/vdsmpki.py", line 126, in _getSPICEcerts
  File "/usr/lib/python2.7/site-packages/otopi/plugin.py", line 942, in execute
RuntimeError: Command '/bin/openssl' failed to execute

Version-Release number of selected component (if applicable):


How reproducible:
depends on the timing

Steps to Reproduce:
1.Start the deploy 
2.Interrupted the deployment by Ctrl+c combination.

Actual results:
The ERROR above

Expected results:
hosted engine does a proper cleaning before it starts or when it is interrupted.

Additional info:
issue is caused by existing file
which is empty. When the file is removed, the deployment can be started again.
Comment 1 Sandro Bonazzola 2016-02-15 06:00:03 EST
Roman, does this happen on RHEV-H only? Or on RHEL as well?
Comment 2 Roman Hodain 2016-02-15 08:13:45 EST
(In reply to Sandro Bonazzola from comment #1)
> Roman, does this happen on RHEV-H only? Or on RHEL as well?

No idea I did not hit this in RHEL, but it does not seem to be RHEV-H related.
Comment 3 Simone Tiraboschi 2016-03-22 09:29:48 EDT

*** This bug has been marked as a duplicate of bug 1001181 ***

Note You need to log in before you can comment on or make changes to this bug.