Bug 1306308 - RSS feeds for datastore alerts has incorrect title 'VM:'
RSS feeds for datastore alerts has incorrect title 'VM:'
Status: CLOSED ERRATA
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Control (Show other bugs)
5.5.0
Unspecified Unspecified
unspecified Severity unspecified
: GA
: 5.6.0
Assigned To: Lucy Fu
Dmitry Misharov
control:alert
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-10 09:23 EST by Vadim Rutkovsky
Modified: 2016-06-29 11:37 EDT (History)
6 users (show)

See Also:
Fixed In Version: 5.6.0.1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-06-29 11:37:08 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:1348 normal SHIPPED_LIVE CFME 5.6.0 bug fixes and enhancement update 2016-06-29 14:50:04 EDT

  None (edit)
Description Vadim Rutkovsky 2016-02-10 09:23:02 EST
Description of problem:
RSS feeds for datastore alerts have incorrect title and invalid link

Version-Release number of selected component (if applicable):
5.5.2.4

How reproducible:
Always

Steps to Reproduce:
1. Create a new alert based on datastore (e.g. hourly alert for low free space using 'Datastore : Free Space Percent of Total < 20 ' expression)
2. Wait for alert to be triggered
3. Check All Alerts RSS feed

Actual results:
RSS entry has 'VM: ' title and doesn't have details for affected datastore

Expected results:
RSS entry title should contain datastore name and link to storage detail page

Additional info:
Email notification contain correct entity type and name

Sample RSS feed: https://10.3.8.226/alert/rss?feed=all_alert_event
Comment 2 CFME Bot 2016-03-23 17:20:41 EDT
New commit detected on ManageIQ/manageiq/master:
https://github.com/ManageIQ/manageiq/commit/f55b7855183b89f4ee119a7c266151d02cb5bda9

commit f55b7855183b89f4ee119a7c266151d02cb5bda9
Author:     Lucy Fu <lufu@redhat.com>
AuthorDate: Tue Mar 1 15:11:55 2016 -0500
Commit:     Lucy Fu <lufu@redhat.com>
CommitDate: Tue Mar 15 11:34:00 2016 -0400

    MiqAction#action_evm_event should raise MiqEvent instead of EmsEvent.
    
    Usually EmsEvent is used for provider events and MiqEvent is used for MIQ events.
    Keep the fields in MiqEvent for EVMAlertEvent. These fields are checked by event_where_clause.
    
    Alert can be set based on Datastores. But EmsEvent does not have a field for datastore.
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1306308

 app/models/miq_action.rb       |  3 ++-
 spec/models/miq_action_spec.rb | 31 ++++++++++++++++++++-----------
 2 files changed, 22 insertions(+), 12 deletions(-)
Comment 3 CFME Bot 2016-03-23 17:20:45 EDT
New commit detected on ManageIQ/manageiq/master:
https://github.com/ManageIQ/manageiq/commit/5b1183c2e0995687475f5e40b7260eac4ee0042d

commit 5b1183c2e0995687475f5e40b7260eac4ee0042d
Author:     Lucy Fu <lufu@redhat.com>
AuthorDate: Tue Mar 1 15:13:24 2016 -0500
Commit:     Lucy Fu <lufu@redhat.com>
CommitDate: Tue Mar 15 11:34:00 2016 -0400

    Change Alert related RSS feeds to look at MiqEvent instead of EmsEvent.
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1306308

 product/alerts/rss/all_alert_event.yml     | 21 ++++++++-------------
 product/alerts/rss/cluster_alert_event.yml | 22 +++++++++++-----------
 product/alerts/rss/host_alert_event.yml    | 22 +++++++++++-----------
 product/alerts/rss/vm_alert_event.yml      | 22 +++++++++++-----------
 4 files changed, 41 insertions(+), 46 deletions(-)
Comment 4 CFME Bot 2016-03-23 17:20:49 EDT
New commit detected on ManageIQ/manageiq/master:
https://github.com/ManageIQ/manageiq/commit/50085ffdbdb9e282dc980d83040399bed6670ffe

commit 50085ffdbdb9e282dc980d83040399bed6670ffe
Author:     Lucy Fu <lufu@redhat.com>
AuthorDate: Tue Mar 15 10:01:02 2016 -0400
Commit:     Lucy Fu <lufu@redhat.com>
CommitDate: Tue Mar 15 11:34:43 2016 -0400

    Let Timeline check EventStream class.
    
    So Timeline can get both EmsEvent and MiqEvent for EVMAlertEvent.
    https://bugzilla.redhat.com/show_bug.cgi?id=1306308

 app/controllers/application_controller/timelines.rb | 4 ++--
 app/models/container.rb                             | 2 +-
 app/models/container_group.rb                       | 2 +-
 app/models/container_node.rb                        | 2 +-
 app/models/container_project.rb                     | 2 +-
 app/models/container_replicator.rb                  | 2 +-
 app/models/host.rb                                  | 2 +-
 app/models/vm_or_template.rb                        | 2 +-
 8 files changed, 9 insertions(+), 9 deletions(-)
Comment 5 CFME Bot 2016-03-23 17:20:52 EDT
New commit detected on ManageIQ/manageiq/master:
https://github.com/ManageIQ/manageiq/commit/2f400dd157cf3302627dbbbf0477102dc001bfe8

commit 2f400dd157cf3302627dbbbf0477102dc001bfe8
Author:     Lucy Fu <lufu@redhat.com>
AuthorDate: Tue Mar 15 10:08:49 2016 -0400
Commit:     Lucy Fu <lufu@redhat.com>
CommitDate: Tue Mar 15 11:34:53 2016 -0400

    Timeline needs the event timestamp to sort the events.
    
    MiqEvent of EVMAlertEvent is checked by Timeline.
    https://bugzilla.redhat.com/show_bug.cgi?id=1306308

 app/models/miq_event.rb | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)
Comment 6 CFME Bot 2016-03-23 17:20:56 EDT
New commit detected on ManageIQ/manageiq/master:
https://github.com/ManageIQ/manageiq/commit/1a0ca0cd6cb497e68d133747ba5b62df34fa1e23

commit 1a0ca0cd6cb497e68d133747ba5b62df34fa1e23
Author:     Lucy Fu <lufu@redhat.com>
AuthorDate: Tue Mar 15 10:59:31 2016 -0400
Commit:     Lucy Fu <lufu@redhat.com>
CommitDate: Tue Mar 15 12:05:35 2016 -0400

    Add migration to convert EVMAlertEvent from EmsEvent to MiqEvent.
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1306308

 ...07205816_fix_event_class_for_evm_alert_event.rb |  53 +++++++
 ...816_fix_event_class_for_evm_alert_event_spec.rb | 161 +++++++++++++++++++++
 2 files changed, 214 insertions(+)
 create mode 100644 db/migrate/20160307205816_fix_event_class_for_evm_alert_event.rb
 create mode 100644 spec/migrations/20160307205816_fix_event_class_for_evm_alert_event_spec.rb
Comment 7 Dmitry Misharov 2016-04-19 10:41:52 EDT
Verified fixed in 5.6.0.1-beta2.20160413141124_e25ac0e. RSS feeds for datastore have proper name and working links.
Comment 9 errata-xmlrpc 2016-06-29 11:37:08 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1348

Note You need to log in before you can comment on or make changes to this bug.