Bug 1306313 - Find causes core dump
Find causes core dump
Status: CLOSED DUPLICATE of bug 1305063
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: findutils (Show other bugs)
6.8
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Kamil Dudka
BaseOS QE - Apps
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-10 09:39 EST by Radka Skvarilova
Modified: 2016-02-11 15:35 EST (History)
0 users

See Also:
Fixed In Version: findutils-4.4.2-9.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-11 15:35:31 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Crash report from abrt (deleted)
2016-02-10 09:39 EST, Radka Skvarilova
no flags Details
Crash report from abrt (12.26 KB, text/plain)
2016-02-10 09:41 EST, Radka Skvarilova
no flags Details

  None (edit)
Description Radka Skvarilova 2016-02-10 09:39:16 EST
Description of problem:
Abrt check show core dump after using find in the test on RHEL 6.8.

Version-Release number of selected component (if applicable):
pkg_name:       findutils
pkg_release:    8.el6
pkg_version:    4.4.2

kernel:         2.6.32-604.el6.x86_64


How reproducible:
Using find in some test - not 100%

Steps to Reproduce:

One of our test for cups (/CoreOS/cups/scheduler/ssl-crash ) uses find:
      find / -name a -a -name b 2>/dev/null 


Actual results:
use ./runtest.sh: line 80:  8315 Aborted      (core dumped) find / -name a -a -name b 2> /dev/null

Expected results:
No core dump

Additional info:
add attachment with abrt output
Comment 2 Radka Skvarilova 2016-02-10 09:41 EST
Created attachment 1122818 [details]
Crash report from abrt
Comment 3 Kamil Dudka 2016-02-10 09:48:06 EST
I believe this is a duplicate of bug #1305063.  Could you please re-test it with findutils-4.4.2-9.el6?
Comment 5 Radka Skvarilova 2016-02-10 09:52:31 EST
Sure, I will re-test it and send you output.
Comment 6 Radka Skvarilova 2016-02-11 12:19:35 EST
This testing have problem, that the issue is not 100% reproducible, even on the same machine the test pass 4 times and the 5. is fail and then next pass again.

But it looks like, the new package may fix the problem, at least I don't find the core dump with new package.
Comment 7 Kamil Dudka 2016-02-11 15:35:31 EST
Thank you for testing it!  I will close this bug as duplicate but feel free to reopen it in case the latest version of findutils crashes in your environment.  Sorry for the inconveniences.

*** This bug has been marked as a duplicate of bug 1305063 ***

Note You need to log in before you can comment on or make changes to this bug.