Bug 1306321 - Error:undefined method `>' for nil:NilClass [miq_policy/rsop] when clicked on submit button in Control->simulation
Error:undefined method `>' for nil:NilClass [miq_policy/rsop] when clicked o...
Status: CLOSED ERRATA
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: UI - OPS (Show other bugs)
5.5.0
Unspecified Unspecified
high Severity medium
: GA
: 5.5.3
Assigned To: Harpreet Kataria
Taras Lehinevych
error
: ZStream
Depends On: 1304288
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-10 09:49 EST by Chris Pelland
Modified: 2017-08-29 21:24 EDT (History)
9 users (show)

See Also:
Fixed In Version: 5.5.3.2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1304288
Environment:
Last Closed: 2016-04-13 14:43:01 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:0616 normal SHIPPED_LIVE CFME 5.5.3 bug fixes and enhancement update 2016-04-13 18:38:44 EDT

  None (edit)
Comment 2 CFME Bot 2016-02-11 11:03:14 EST
New commit detected on cfme/5.5.z:
https://code.engineering.redhat.com/gerrit/gitweb?p=cfme.git;a=commitdiff;h=417511ff39e82e2364f15c72c1b8c4ce21c4303a

commit 417511ff39e82e2364f15c72c1b8c4ce21c4303a
Merge: c5da485 214a7fe
Author:     Dan Clarizio <dclarizi@redhat.com>
AuthorDate: Thu Feb 11 10:54:21 2016 -0500
Commit:     Dan Clarizio <dclarizi@redhat.com>
CommitDate: Thu Feb 11 10:54:21 2016 -0500

    Merge branch '55z_pr_6559' into '5.5.z'
    
    reset session[:changed] first time on Control/Simulation screen
    
    when coming from another screen sometimes session[:changed] was still set to true causing "Submit" button to be enabled when going to Control/Simulation screen first time causing it to blow up if user pressed submit button without making selections in the form.
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1304288
    https://bugzilla.redhat.com/show_bug.cgi?id=1306321
    (cherry picked from commit ed5a343)
    
    @dclarizi please review, clean cherry-pick for https://github.com/ManageIQ/manageiq/pull/6559
    
    See merge request !776

 app/controllers/miq_policy_controller/rsop.rb      |  1 +
 .../controllers/miq_policy_controller/rsop_spec.rb | 28 ++++++++++++++++++++++
 2 files changed, 29 insertions(+)
Comment 3 CFME Bot 2016-02-11 11:03:43 EST
New commit detected on cfme/5.5.z:
https://code.engineering.redhat.com/gerrit/gitweb?p=cfme.git;a=commitdiff;h=214a7fe25568f3da3a20bd5173797dc724217130

commit 214a7fe25568f3da3a20bd5173797dc724217130
Author:     Harpreet Kataria <hkataria@redhat.com>
AuthorDate: Mon Feb 8 17:20:10 2016 -0500
Commit:     Harpreet Kataria <hkataria@redhat.com>
CommitDate: Wed Feb 10 14:15:33 2016 -0500

    reset session[:changed] first time on Control/Simulation screen
    
    when coming from another screen sometimes session[:changed] was still set to true causing "Submit" button to be enabled when going to Control/Simulation screen first time causing it to blow up if user pressed submit button without making selections in the form.
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1304288
    https://bugzilla.redhat.com/show_bug.cgi?id=1306321
    (cherry picked from commit ed5a343)

 app/controllers/miq_policy_controller/rsop.rb      |  1 +
 .../controllers/miq_policy_controller/rsop_spec.rb | 28 ++++++++++++++++++++++
 2 files changed, 29 insertions(+)
 create mode 100644 spec/controllers/miq_policy_controller/rsop_spec.rb
Comment 5 Taras Lehinevych 2016-03-28 05:31:12 EDT
Verified in 5.5.3.2
Comment 7 errata-xmlrpc 2016-04-13 14:43:01 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:0616

Note You need to log in before you can comment on or make changes to this bug.