Bug 1306323 - Memory leak introduced by modesetting double-shadow patch
Memory leak introduced by modesetting double-shadow patch
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: xorg-x11-server (Show other bugs)
7.2
x86_64 Linux
urgent Severity urgent
: rc
: ---
Assigned To: Adam Jackson
Desktop QE
: OtherQA, Regression, ZStream
Depends On:
Blocks: 1203710 1245518 1340486 1364088
  Show dependency treegraph
 
Reported: 2016-02-10 10:05 EST by Martin Wilck
Modified: 2016-11-03 22:50 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1340486 (view as bug list)
Environment:
Last Closed: 2016-11-03 22:50:42 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch for memory leak (861 bytes, patch)
2016-02-10 10:05 EST, Martin Wilck
no flags Details | Diff

  None (edit)
Description Martin Wilck 2016-02-10 10:05:42 EST
Created attachment 1122821 [details]
Patch for memory leak

Description of problem:
The patch for slow mgag200 video from bug #1152233 introduces a memory leak in the server.

Version-Release number of selected component (if applicable):
1.17.2-10.el7


How reproducible:
always


Steps to Reproduce:
1. on a system with mgag200/modesetting, run freqent screen updates e.g. by running "ls -lR /" in an xterm

Actual results:
Xorg process' memory usage increases constantly, until Xorg is OOM killed at some point.

Expected results:
No memory leak


Additional info:
The attached patch fixes this. I already verified it.
Comment 13 errata-xmlrpc 2016-11-03 22:50:42 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2293.html

Note You need to log in before you can comment on or make changes to this bug.