This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1306328 - Update devtoolset-toolchain-docker image to DTS 4.1 components' versions
Update devtoolset-toolchain-docker image to DTS 4.1 components' versions
Status: CLOSED ERRATA
Product: Red Hat Developer Toolset
Classification: Red Hat
Component: devtoolset-4-toolchain-docker (Show other bugs)
DTS 4.1 RHEL 7
Unspecified Unspecified
unspecified Severity unspecified
: beta1
: 4.1
Assigned To: Marek Polacek
Miloš Prchlík
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-10 10:11 EST by mbenitez
Modified: 2016-05-31 06:45 EDT (History)
6 users (show)

See Also:
Fixed In Version: devtoolset-4-toolchain-docker-4-9.3-x86_64.tar.gz
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-05-31 06:45:55 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description mbenitez 2016-02-10 10:11:58 EST

    
Comment 3 Marek Polacek 2016-03-29 12:12:28 EDT
I'm not sure how to go about this one.  I've tried the latest version of devtoolset-4-toolchain-docker, devtoolset-4-toolchain-docker-4-9.2-x86_64.tar.gz, but that has still the old version of gcc:

bash-4.2$ gcc --version
gcc (GCC) 5.2.1 20150902 (Red Hat 5.2.1-2)

But I don't think there's anything to change in the Dockerfile:

RUN yum-config-manager --enable rhel-server-rhscl-7-rpms && \
    yum-config-manager --enable rhel-7-server-optional-rpms && \
    yum-config-manager --disable epel >/dev/null || : && \
    yum install -y --setopt=tsflags=nodocs devtoolset-4-gcc devtoolset-4-gcc-c++ devtoolset-4-gcc-gfortran devtoolset-4-gdb && \
    yum clean all -y

so it seems that this should pull in the newest version of devtoolset-4-gcc from rhel-server-rhscl-7-rpms or rhel-7-server-optional-rpms.  Perhaps devtoolset-4-gcc-5.3.1-4.el7 isn't in those repos yet?

Honza, would you know more?
Comment 4 Marek Polacek 2016-04-01 09:07:39 EDT
hhorak seems to be on PTO; trying someone else ;).
Comment 5 Radek Zima 2016-04-04 05:25:23 EDT
Hi,

newer gcc package is not inside these repositories. See

dhcp-24-140:rzima ~ $  repoquery --repoid='rz' --repofrompath=rz,http://pulp.dist.prod.ext.phx2.redhat.com/content/dist/rhel/server/7/7Server/x86_64/rhscl/1/os/ -q devtoolset-4-gcc*
devtoolset-4-gcc-0:5.2.1-2.2.el7.x86_64
devtoolset-4-gcc-c++-0:5.2.1-2.2.el7.x86_64
devtoolset-4-gcc-gdb-plugin-0:5.2.1-2.2.el7.x86_64
devtoolset-4-gcc-gfortran-0:5.2.1-2.2.el7.x86_64
devtoolset-4-gcc-plugin-devel-0:5.2.1-2.2.el7.x86_64
dhcp-24-140:rzima ~ $  repoquery --repoid='rz' --repofrompath=rz,http://download.lab.bos.redhat.com/rel-eng/updates/RHEL-7.2-20160322.3/compose/Server-optional/x86_64/os/ -q devtoolset-4-gcc*

Rebuild will be needed after update.

Regards,
Radek
Comment 6 Marek Polacek 2016-04-04 09:36:13 EDT
Thanks.  Seems that a pure rebuild helped:
$ docker run -i -t a6d5720f4795 gcc --version
gcc (GCC) 5.3.1 20160212 (Red Hat 5.3.1-4)
Comment 8 Miloš Prchlík 2016-04-20 03:42:57 EDT
Verified for build rhscl/devtoolset-4-toolchain-rhel7:4-9.5.
Comment 10 errata-xmlrpc 2016-05-31 06:45:55 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1181

Note You need to log in before you can comment on or make changes to this bug.