Bug 1306334 - ERROR: "DataBase threw an exception: null" is issued when performing certain snapshot related operations
Summary: ERROR: "DataBase threw an exception: null" is issued when performing certain ...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: ovirt-engine
Classification: oVirt
Component: BLL.Storage
Version: 3.6.3
Hardware: Unspecified
OS: Unspecified
medium
medium vote
Target Milestone: ovirt-3.6.5
: 3.6.5
Assignee: Liron Aravot
QA Contact: Elad
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-02-10 15:34 UTC by Natalie Gavrielov
Modified: 2016-05-08 08:18 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-04-21 14:41:53 UTC
oVirt Team: Storage
rule-engine: ovirt-3.6.z+
mgoldboi: planning_ack+
rule-engine: devel_ack+
rule-engine: testing_ack+


Attachments (Terms of Use)
engine.log (259.37 KB, application/x-gzip)
2016-02-10 15:34 UTC, Natalie Gavrielov
no flags Details

Description Natalie Gavrielov 2016-02-10 15:34:06 UTC
Created attachment 1122828 [details]
engine.log

Description of problem:

When creating a snapshot (for nfs storage type)
or when deleting a vm with cinder snapshots

The following error appears in engine.log:
ERROR [org.ovirt.engine.core.bll.tasks.AsyncTaskUtils] (org.ovirt.thread.pool-6-thread-23) [5a63aef8] Adding/Updating task 'e214ee9d-5b7a-4344-9c55-7bb0e504c2b9' to DataBase threw an exception: null

Version-Release number of selected component (if applicable):
rhevm-3.6.3-0.1.el6.noarch

How reproducible:
100%

Steps to Reproduce:

There are two scenarios:

1. Create a snapshot for a vm with nfs disks.
2. Remove a vm with snapshots - cinder based.

Actual results:

The following appears:
ERROR [org.ovirt.engine.core.bll.tasks.AsyncTaskUtils] (org.ovirt.thread.pool-6-thread-23) [5a63aef8] Adding/Updating task 'e214ee9d-5b7a-4344-9c55-7bb0e504c2b9' to DataBase threw an exception: null error

Error is issued for each 'create snapshot' (nfs type).
Error is issued for each disk removed from cinder in the process of removing the vm.

Expected results:

No errors.

Additional info:

* I haven't noticed any other impact.
* Cinder volumes were deleted.
* When removing one single cinder based snapshot error wasn't issued.

Comment 1 Oved Ourfali 2016-02-10 15:44:11 UTC
Moving to storage component.
If it turns out it is infra related, please move it accordingly.

Comment 2 Allon Mureinik 2016-02-10 15:50:38 UTC
The error is thrown from AsyncTaskUtils, but it may very well be since it's being misused - offhand, I can guess it's applied to Cinder "tasks", which aren't AsyncTasks in the traditional sense.

Tentatively targeting to 3.6.5 and assigning Liron to research - if this assessment is incorrect, we'll re-evaluate.

Comment 3 Ondra Machacek 2016-02-22 13:54:28 UTC
isn't this dup of bug 1308868 ?

Comment 4 Allon Mureinik 2016-03-03 15:02:30 UTC
(In reply to Ondra Machacek from comment #3)
> isn't this dup of bug 1308868 ?
Seems so.
Setting to MODIFIED so it can be verified in the next build delivered to QA.

Comment 5 Eyal Edri 2016-03-31 08:35:49 UTC
Bugs moved pre-mature to ON_QA since they didn't have target release.
Notice that only bugs with a set target release will move to ON_QA.

Comment 6 Elad 2016-04-05 10:56:40 UTC
Reproduced over 3.6.3 env. after the following scenario:
- Created VM with thin disk on NFS domain
- Started the VM and created a snapshot with memory saved
- Stopped the VM and previewed the snapshot

2016-04-05 13:43:10,618 ERROR [org.ovirt.engine.core.bll.tasks.AsyncTaskUtils] (org.ovirt.thread.pool-6-thread-19) [47028505] Adding/Updating task 'e3b2a992-5dd8-4789-9999-01449f37b79f' 
to DataBase threw an exception: null


Over 3.6.5 env. , the same scenario doesn't cause to this exception.

Used rhevm-3.6.3-0.1.el6.noarch for clarifying the scenario in which the bug is reproduced.

Verified using:
rhevm-3.6.5-0.1.el6.noarch


Note You need to log in before you can comment on or make changes to this bug.