Bug 1306347 - Cant choose the interface do delete from router on network topology
Cant choose the interface do delete from router on network topology
Status: CLOSED NOTABUG
Product: Red Hat OpenStack
Classification: Red Hat
Component: python-django-horizon (Show other bugs)
8.0 (Liberty)
Unspecified Linux
unspecified Severity medium
: ---
: 8.0 (Liberty)
Assigned To: Itxaka
Ido Ovadia
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-10 11:06 EST by Ido Ovadia
Modified: 2016-02-21 05:45 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-21 05:45:11 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
network interfaces (47.93 KB, image/png)
2016-02-18 07:52 EST, Itxaka
no flags Details
Network Topology (67.76 KB, image/png)
2016-02-20 04:55 EST, Itxaka
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Launchpad 1544133 None None None 2016-02-10 11:08 EST

  None (edit)
Description Ido Ovadia 2016-02-10 11:06:14 EST
Description of problem:
=======================
Cant choose the interface do delete from router on curvature network topology

Version-Release number of selected component:
=============================================
python-django-horizon-8.0.0-10.el7ost.noarch
openstack-dashboard-8.0.0-10.el7ost.noarch

How reproducible:
=================
100%

Steps to Reproduce:
===================
1. Create private network
2. Create external network
3. Create router and connect it both networks 
4. From network topology click no the network icon
5. Click 'Delete Interface'

Actual results:
===============
Cant choose the interface to delete

Expected results:
=================
User can choose the interface to delete from the router  

Additional info:
Comment 1 Itxaka 2016-02-18 07:52:35 EST
I could not reproduce exactly this with a packstack install + openstack 8.0 as shown on the image.


With 4 networks attached I do get the option to delete different interfaces.

What I dont get the option is to clear the external gateway, which is different as this doesnt delete the interface but only disconnects the external gateway IP from the router.

Im guessing that this is the issue that this bug is about, unable to "clear gateway" from the network topology page.

Testing against a devstack install in a few minutes to confirm that the issue is also there.
Comment 2 Itxaka 2016-02-18 07:52 EST
Created attachment 1128215 [details]
network interfaces
Comment 3 Itxaka 2016-02-20 04:54:30 EST
I cant reproduce this on the test env provided by Ido as shown on the attached image, the interfaces attached all have their own "delete interface" button.

What it is indeed missing is a button to "clear gateway" from the only router_gateway interface in the router as shown in the image.

@Ido: should we close this and open a bug for the missing "clear interface" button? Or can you try to reproduce this as maybe Im not following the steps preperly or there is something Im missing?

thanks!
Comment 4 Itxaka 2016-02-20 04:55 EST
Created attachment 1128782 [details]
Network Topology
Comment 5 Ido Ovadia 2016-02-21 05:44:33 EST
(In reply to Itxaka from comment #3)
> I cant reproduce this on the test env provided by Ido as shown on the
> attached image, the interfaces attached all have their own "delete
> interface" button.
> 
> What it is indeed missing is a button to "clear gateway" from the only
> router_gateway interface in the router as shown in the image.
> 
> @Ido: should we close this and open a bug for the missing "clear interface"
> button? Or can you try to reproduce this as maybe Im not following the steps
> preperly or there is something Im missing?
> 
> thanks!

Itxaka,

You right. Try to reproduce it with more than two networks, the bug is that there is no "clear gateway" or "delete interface" on interface which connect to router

https://bugzilla.redhat.com/show_bug.cgi?id=1310399

Note You need to log in before you can comment on or make changes to this bug.