Bug 1306352 - When creating activation keys via hammer you can select subscriptions and view them via hammer but you cannot do the same with specific content selections
When creating activation keys via hammer you can select subscriptions and vie...
Status: CLOSED WONTFIX
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Hammer (Show other bugs)
6.1.6
Unspecified Unspecified
unspecified Severity medium (vote)
: Unspecified
: --
Assigned To: satellite6-bugs
Katello QA List
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-10 11:16 EST by Chuck Mead
Modified: 2017-08-04 09:19 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-08-04 09:19:05 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Chuck Mead 2016-02-10 11:16:07 EST
Description of problem: When creating activation keys via hammer you can select subscriptions *and view them* via hammer commands but you cannot do the same with specific content selections. Here is an example command:

hammer activation-key content-override --id 2 --organization Customer --content-label rhel-7-server-satellite-tools-6.1-rpms --value 0

It appears this is an omission in functionality and since there *IS* the capability to do this in the GUI I suggest we add the omitted functionality to hammer. See the example in "Steps to Reproduce".

As far as it goes the process works but we're missing key functionality to maintain parity with the GUI.


Version-Release number of selected component (if applicable): whatever hammer is included in satellite release 6.1.6


How reproducible: 


Steps to Reproduce:
1. hammer activation-key create --name=ak_RHEL6_CV_Dev --organization Customer --content-view=RHEL6_CV --lifecycle-environment=Dev
2. hammer activation-key list --organization Customer
3. hammer activation-key add-subscription --id=2 --subscription-id=8af99c1e52c1cfc50152c6b495320153
4. hammer activation-key content-override --id 2 --organization Customer --content-label rhel-7-server-satellite-tools-6.1-rpms --value 0

Actual results:


Expected results:


Additional info:
Comment 1 Bryan Kearney 2016-07-26 15:05:13 EDT
Moving 6.2 bugs out to sat-backlog.
Comment 2 Bryan Kearney 2017-08-04 09:19:05 EDT
Thank you for your interest in Satellite 6. We have evaluated this request, and we do not expect this to be implemented in product in the forseeable future. We are therefore closing this out as WONTFIX. If you have any concerns about this, please feel free to contact Rich Jerrido or Bryan Kearney. Thank you.

Note You need to log in before you can comment on or make changes to this bug.