Bug 1306360 - Cant delete subnet on curvature network topology
Cant delete subnet on curvature network topology
Status: CLOSED NOTABUG
Product: Red Hat OpenStack
Classification: Red Hat
Component: python-django-horizon (Show other bugs)
8.0 (Liberty)
x86_64 Linux
unspecified Severity medium
: ---
: 8.0 (Liberty)
Assigned To: Itxaka
Ido Ovadia
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-10 11:35 EST by Ido Ovadia
Modified: 2016-09-27 03:49 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-04-07 04:56:19 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
deleting subnets (468.71 KB, video/mp4)
2016-02-20 05:19 EST, Itxaka
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Launchpad 1544155 None None None 2016-02-10 11:39 EST

  None (edit)
Description Ido Ovadia 2016-02-10 11:35:48 EST
Description of problem:
=======================
Cant delete subnet on curvature network topology

Version-Release number of selected component:
=============================================
python-django-horizon-8.0.0-10.el7ost.noarch
openstack-dashboard-8.0.0-10.el7ost.noarch

How reproducible:
=================
100%

Steps to Reproduce:
===================
1. Create network and subnet
2. From network topology click no the network icon
3. Click 'Delete Subnet'

Actual results:
===============
Subnet does not delete

Expected results:
=================
Subnet should delete


Additional info /var/log/horizon/horizon.log
============================================
2016-02-10 16:33:00,323 5577 WARNING horizon.exceptions Recoverable error: The server has either erred or is incapable of performing the requested operation. (HTTP 500) (Request-ID: req-ddd3f281-ea79-4bf0-939f-4a8267ad47d1)
Comment 1 Itxaka 2016-02-20 05:19:10 EST
Cant reproduce on the environment provided by Ido.

Attached a small video on network topology while deleting 3 subnets.


What I did found on the environment provided before the actual one was that due to some error on cinder (which returned the exact error provided in the bug description[0]) the network topology keep reloading due to obtaining that error instead of the usual updated json on each ajax request.

This could easily affect the action of deleting a subnet, especially on a high latency environment in which the delete action takes time to execute, the ajax update for the network topology seemed to cause page issues which lead to the action never taking place in the first time (network calls returned the error at the top).

So this could be a problem that arises only when the openstack components are wrongly configured or malfunctioning.




[0] 2016-02-10 16:33:00,323 5577 WARNING horizon.exceptions Recoverable error: The server has either erred or is incapable of performing the requested operation. (HTTP 500) (Request-ID: req-ddd3f281-ea79-4bf0-939f-4a8267ad47d1)
Comment 2 Itxaka 2016-02-20 05:19 EST
Created attachment 1128783 [details]
deleting subnets
Comment 3 Itxaka 2016-04-04 07:57:33 EDT
Ido, can this be closed? have you been able to reproduce it again?
Comment 4 Itxaka 2016-04-07 04:56:19 EDT
Ido, Im closing this as it has been a long time. Please, feel free to open it again if you are able to reproduce it again.

thanks!

Note You need to log in before you can comment on or make changes to this bug.