Bug 1306384 - Neutron is not configured to use the rootwrap daemon
Neutron is not configured to use the rootwrap daemon
Status: CLOSED CURRENTRELEASE
Product: Red Hat OpenStack
Classification: Red Hat
Component: rhosp-director (Show other bugs)
8.0 (Liberty)
Unspecified Unspecified
high Severity high
: ---
: 10.0 (Newton)
Assigned To: Brent Eagles
Shai Revivo
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-10 12:03 EST by Terry Wilson
Modified: 2016-10-14 14:38 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-10-14 14:38:55 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Terry Wilson 2016-02-10 12:03:52 EST
Description of problem:

Neutron is not configured to use rootwrap daemon mode. Enabling daemon mode increases performance, especially when a machine has many interfaces (as networking nodes tend to have).

Version-Release number of selected component (if applicable):


How reproducible:

Always

Steps to Reproduce:
1. Install openstack

Actual results:
root_helper_daemon is unset in neutron.conf's [agent] section

Expected results:
neutron.conf contains both root_helper and root_helper_daemon configs, like:

[agent]
root_helper = sudo neutron-rootwrap /etc/neutron/rootwrap.conf
root_helper_daemon = sudo neutron-rootwrap-daemon /etc/neutron/rootwrap.conf
Comment 1 Brent Eagles 2016-02-12 15:27:36 EST
Is it the case that the configuration file has it actually blanked out?

One of the challenges here is that the puppet modules for neutron don't "know" about the root_helper_daemon, so 3 projects need changing:

- puppet-neutron
- openstack-puppet-modules (the changes are made to the above first and sync'ed in)
- tripleo-heat-templates 

The other more direct route might be to simply add the option to the proper tripleo-image-element(s). Looking at the neutron.conf element it looks like root_helper is initialized with a hard coded value already. This might be the way to go while we propagate the configuration through the normal route.
Comment 2 Mike Burns 2016-04-07 17:07:13 EDT
This bug did not make the OSP 8.0 release.  It is being deferred to OSP 10.
Comment 4 Assaf Muller 2016-10-14 14:38:55 EDT
Brent verified that rootwrap-daemon is configured on OSP 10. I don't see the need for docs and since Brent verified it just now, I don't see a need for QE, so I'm closing the bug.

Note You need to log in before you can comment on or make changes to this bug.