Bug 1306393 - unexpand chokes on empty lines
unexpand chokes on empty lines
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: coreutils (Show other bugs)
23
i686 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Ondrej Vasik
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-10 12:16 EST by vvs
Modified: 2016-02-16 22:49 EST (History)
7 users (show)

See Also:
Fixed In Version: coreutils-8.24-6.fc23
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-16 22:49:40 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description vvs 2016-02-10 12:16:47 EST
Description of problem:

unexpand doesn't like when there are empty lines in a file and finishes abruptly.

Version-Release number of selected component (if applicable):

coreutils-8.24-5

How reproducible:

Always

Steps to Reproduce:
1. echo >test.txt
2. unexpand test.txt

Actual results:

unexpand: input line is too long

Expected results:

it should successfully process all lines.

Additional info:
Comment 1 Ondrej Vasik 2016-02-10 17:58:11 EST
As a temporary workaround, please try to use C locales. With LC_ALL=C unexpand it should not happen. I assume this is caused by recent changes in downstream implementation of i18n patch. Can you confirm?
Comment 2 vvs 2016-02-10 21:49:41 EST
Unfortunately it didn't help. Nothing changed.
Comment 3 Fedora Update System 2016-02-15 02:19:11 EST
coreutils-8.24-6.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2016-c6e4ae0beb
Comment 4 Fedora Update System 2016-02-16 22:49:37 EST
coreutils-8.24-6.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.